vovababkin1477
?>

Машина выехала из пункта А в пункт В, между которыми Sкм. Машина двигалась с постоянной скоростью V и остановилась через t часов. Напишите программу, которая по введенным S, V, t определяет положение машины относительно пункта В: не доехала, приехала, проехала. Паскаль

Информатика

Ответы

maksteks
Pascal:
var n,a,s:longint;
begin
  repeat
    write ('N = ');
    readln(n);
  until n in [10..99];
  write ('A = ');
  readln(a);
  s:=0;
  while n<>0 do
    begin
       s:=s+n mod 10;
       n:=n div 10;
    end;
  if s>a then writeln ('YES') else writeln ('NO');
  readln;
end.

C++:
#include <iostream>
using namespace std;

int main()
{
   int a,n,s = 0;
   do
   {
      cout <<"N = ";
      cin >>n;
   }
   while (n<10 || n>99);
   cout <<"A = ";
   cin >>a;
   while (n!=0)
   {
     s+=n%10;
     n/=10;
   }
   if (s>a)
      cout <<"YES" <<endl;
   else cout <<"NO" <<endl;
   return 0;
}
info40
// PascalABC.NET 3.0, сборка 1139 от 10.01.2016
begin
  var s:=ReadLnString('Вводите:');
  s.ToWords.Where(x->x=ReverseString(x)).PrintLn;
end.

Тестовое решение:
Вводите: дед иван достал наган и пошел с ним в шалаш
дед наган и с в шалаш

Вариант, если исключить однобуквенные:

// PascalABC.NET 3.0, сборка 1139 от 10.01.2016
begin
  var s:=ReadLnString('Вводите:');
  s.ToWords.Where(x->x=ReverseString(x)).
    Where(x->x.Length>1).PrintLn;
end.

Тестовое решение:
Вводите: дед иван достал наган и пошел с ним в шалаш
дед наган шалаш

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Машина выехала из пункта А в пункт В, между которыми Sкм. Машина двигалась с постоянной скоростью V и остановилась через t часов. Напишите программу, которая по введенным S, V, t определяет положение машины относительно пункта В: не доехала, приехала, проехала. Паскаль
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Банова_Елена431
Кедрин Карлен
vladimirdoguzov
Сергеевна-С.А.1549
motor2218
alexeytikhonov
fashbymsk
zapros
bureiko
Olgax732
Petrushin482
Баранов276
milanparipovic864
blackpoint2020273
Olegmgu11986