allo22-27
?>

Автобусный билет имеет номер из четырёх цифр. Билет считают счастливым, если сумма двух первых цифр билета равна сумме двух последних цифр. Требуется составить программу определения билета, имеющего счастливый номер на div и

Информатика

Ответы

Vladimirovna Dmitrieva

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

program biletik;

var  

a: array [1..6] of integer;

i,b: integer;

 

begin

writeln('Введите номер билетика');

readln(b);

if (b<1000000) and (b>99999)   then

begin

for i:=1 to 6 do

begin

a[i]:=b mod 10;

b:=b div 10;

end;

if (a[1]+a[2]+a[3]=a[4]+a[5]+a[6]) then

writeln('Билетик счастливый')

else

writeln('Билетик несчастливый');

end

else writeln('Номер должен быть шестизначным');

end.

Объяснение:

nikv568734
Текстовый редактор -самостоятельная компьютерная программа или компонент программного комплекса предназначенная для создания и изменения текстовых данных в общем и текстовых файлов.
*про ПУСК*
Стрелочки, имеющиеся справа от некоторых позиций меню, означают наличие для этих пунктов меню дополнительных подменю. Такое меню часто называют каскадным.
*режим переноса по словам в блокноте*
Формат -> Перенос по словам
*про выход из блокнота*
1.Alt+F4
2.Файл - Выход
3.Нажать на крестик наверху справа
4.Через панель задач
5.Через диспетчер задач
*про клаву*
предназначена для ввода информации, логично, верно
*про группы клавиш*
1.Служебные клавиши для редактирования. Space (пробел) - это самая длинная клавиша, которая расположена в нижней части клавиатуры. Название клавиши говорит само за себя, она вставляет пробелы между символами, словами и предложениями;
2.Специальные клавиши клавиатуры.
Esc - клавиша отменить последнее действие. Дословно переводиться как бежать, совершать побег;
3.Функциональные клавиши на клавиатуре. Function keys - в эту группу входят клавиши из верхнего ряда кнопочной доски - от F1 до F12.
4.Клавиши управления курсором. Всего таких клавиш на клавиатуре восемь. К этой группе относятся стрелки, а также клавиши:
Home - перемещение курсора в начало строки;
End - отправляет курсор в конец строки;
Page UP - поднимет курсор на страницу вверх;
Page Down - опускает курсор на страницу вниз;
5.Цифровой блок клавиатуры. Numeric keypad (цифровая клавиатура) -эта группа образует прямоугольник в правой части клавиатуры. Группа содержит в себе цифровые клавиши от 0 до 9, символы сложения, вычитания, умножения и деления.
6.Вс клавиши на клавиатуре. Print Screen - с ее можно скопировать содержимое экрана в буфер обмена, а полученное таким изображение называется скриншотом. Находящийся в буфере обмена скриншот можно вставить в любую программу, которая умеет работать с изображениями.
WIN - вызывает главное меню Windows, а в сочетании с другими клавишами упрощает работу за компьютером, экономя время и силы. На клавише изображен логотип корпорации Microsoft;
*про дипломант*
образовано суффиксальным "диплом" + суфикс -ант- = дипломант
tatk00
Магистрально-модульный принцип построения компьютера

В основу архитектуры современных персональных компьютеров положен магистрально-модульный принцип. Модульный принцип позволяет потребителю самому комплектовать нужную ему конфигурацию компьютера и производить при необходимости ее модернизацию. Модульная организация компьютера опирается на магистральный (шинный) принцип обмена информацией между устройствами.  
Магистраль (системная шина) включает в себя три многоразрядные шины: шину данных, шину адреса и шину управления, которые представляют собой многопроводные линии. К магистрали подключаются процессор и оперативная память, а также периферийные устройства ввода, вывода и хранения информации, которые обмениваются информацией на машинном языке (последовательностями нулей и единиц в форме электрических импульсов) .

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Автобусный билет имеет номер из четырёх цифр. Билет считают счастливым, если сумма двух первых цифр билета равна сумме двух последних цифр. Требуется составить программу определения билета, имеющего счастливый номер на div и
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

myhauz
kolesnikovaen
Владислав1246
citioil15
mospaskrasnogorbukh
korchags19983941
tata-novik
Nastyaches4
iv1as2
Nazaruk_Kodochigov
sargisyan
YuRII1236
bd201188
slipu817838
ivanjeka87
▲