MDubovikov73
?>

Задан двумерный целочисленный массив А из n строк и m столбцов (1 ≤ n, m ≤ 10 Составить программу, которая формирует одномерный массив В, каждый элемент которого есть произведение элементов массива А в соответствующей строке.

Информатика

Ответы

мария Кузив1393

//g++ -Wall -o 1 1.cpp

//./1

#include <iostream>

#include <algorithm>

#include <vector>

using namespace std;

int main() {

   int n;

   cin>>n;

   if (n == 0){

       cout<<0;

       return 0;

   }

   else{

       int a1 = 0 , a2 = 1;

       int c = 1;

       while(a2<=n){

           if (a2==n){

               cout<<c;

               return 0;

           }

           a1 = a2;

           a2 = a1+a2;

           c++;

       }

       cout<<-1;

       return 0;

   }

}

Объяснение:

Andreevna_Grebenshchikova155
Что мы знаем о войне немного  по рассказам бабушек и мам  знаем, что надежда и тревога  об руку ходили по домам  слухи зависали  как знамена  дымом застилался горизонт  многоверстный и многоименный  жаждал крови ненасытный фронт  а из тыла за волной волна  шла латать верховные промашкивсасывала мальчиков война   и выплевывала мертвые бумажкикаждый шаг   к победе ли к бедесводки измеряли расстояньем  даже самый распобедный день  был комуто вечным расставаньемгоды возвращающий экраночевидцев честные романывсе равно останутся обманомссадины не заменяют рантолько изредка за толщей дней  вдруг всплеснёт сирены голос лютыйзамирая криками детей  и застынет сердце на минуту

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Задан двумерный целочисленный массив А из n строк и m столбцов (1 ≤ n, m ≤ 10 Составить программу, которая формирует одномерный массив В, каждый элемент которого есть произведение элементов массива А в соответствующей строке.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

marat-dzhanibekov
mirogall
borodin
vladimyrgorbunov
admiralbany
Маркина Ворошилина
ИНФОРМАТИКА НАПИСАТЬ ПРОГРАММУ ПИТОН
pivenraisa
Максим
osipov1984osipov
MislitskiiSergei1403
marinazubcko16729
yana2211
anadtacia03108988
Михаил1121
daverkieva568
▲