#include <iostream>
using namespace ::std;
int main()
{
setlocale(LC_CTYPE , "rus");
int n, i, j = 0, k = 0;
double s = 0;
cout << "Введите количество элементов: \n";
cin >> n;
float x;
float *massiv = new float[n];
if (!massiv)
{
cout << "Сбой программы!\n";
system("pause");
return 0;
}
cout << "Введите массив с " << ' ' << n << ' ' << "элементов\n";
for (i = 0; i < n; i++)
cin >> *(massiv + i);
cout << "Заданный массив: " << endl;
for (int i = 0; i < n; i++)
cout << *(massiv + i) << ' ' << endl;
for (i = 0; i<n; i++)
{
if (massiv[i]>0)
k++;
}
cout << " Количество положительных элементов = " << k << '\n';
for (i = 0; i<n; i++)
{
if (massiv[i] == 0) {
j = massiv[i];
x = i;
}
}
for (i = x; i<n; i++)
s += massiv[i];
cout << "Сумма =" << s;
float *massiv2 = new float[n];
if (!massiv2)
{
cout << "Сбой программы !\n";
system("pause");
return 0;
}
for (i = 0; i < n; i++)
if (massiv[i] <= 1)
{
massiv2[j] = massiv[i];
j++;
}
for (i = 0; i < n; i++)
if (fabs(massiv[i]) > 1)
{
massiv2[j] = massiv[i];
j++;
}
cout << endl << "Отсортированный массив: " << endl;
for (int j = 0; j < n; j++)
cout << '\n' << massiv2[j] << ' ';
delete[] massiv;
delete[] massiv2;
system("pause");
return 0;
}
В работо не сомневайся.
ответ:1) (1 б.) Верные ответы: 3;
2) (1 б.) Верные ответы: 4;
3) (1 б.) Верные ответы: 1; 2;
4) (1 б.) Верные ответы: 3;
5) (1 б.) Верные ответы: 1;
6) (1 б.) Верные ответы: 3;
7) (1 б.) Верные ответы: 4;
8) (1 б.) Верные ответы: 1;
9) (1 б.) Верные ответы: 3;
10) (1 б.) Верные ответы: 3;
11) (1 б.) Верные ответы: 2;
12) (1 б.) Верные ответы: 3;
13) (1 б.) Верные ответы: 4;
14) (1 б.) Верные ответы: 1;
15) (1 б.) Верные ответы: 1; 2;
16) (1 б.) Верные ответы: 1;
17) (1 б.) Верные ответы: 2;
18) (1 б.) Верные ответы: 1;
19) (1 б.) Верные ответы: 3;
20) (1 б.) Верные ответы: 2;
21) (1 б.) Верные ответы: 2;
Объяснение:
Поделитесь своими знаниями, ответьте на вопрос:
1. Исполнитель Калькулятор преобразует число на экране. У исполнителя есть две команды, которым присвоены номера: (1 Прибавить 1; (2). Прибавить 3. Программа для исполнителя Калькулятор – это последовательность команд. Сколько существует программ, для которых при исходном числе 3 результатом является число 21 и при этом траектория вычислений содержит число 12 и не содержит числа 18? 2. Исполнитель Калькулятор преобразует число на экране. У исполнителя есть две команды, которым присвоены номера: (1). Прибавить 1; (2). Умножить на 2. Программа для исполнителя Калькулятор – это последовательность команд. Сколько существует программ, для которых при исходном числе 2 результатом является число 33 и при этом траектория вычислений содержит число 16 и не содержит числа 30? 3. Исполнитель Калькулятор преобразует число на экране. У исполнителя есть две команды, которым присвоены номера: (1). Прибавить 1; (2). Прибавить 3. Программа для исполнителя Калькулятор – это последовательность команд. Сколько существует программ, для которых при исходном числе 5 результатом является число 25 и при этом траектория вычислений содержит число 15 и не содержит числа 12? 4. Исполнитель Калькулятор преобразует число на экране. У исполнителя есть две команды, которым присвоены номера: (1). Прибавить 1; (2). Умножить на 2. Программа для исполнителя Калькулятор – это последовательность команд. Сколько существует программ, для которых при исходном числе 2 результатом является число 34 и при этом траектория вычислений содержит число 12? 5. Исполнитель Калькулятор преобразует число на экране. У исполнителя есть две команды, которым присвоены номера: (1). Прибавить 1; (2). Умножить на 2. Программа для исполнителя Калькулятор – это последовательность команд. Сколько существует программ, для которых при исходном числе 2 результатом является число 40 и при этом траектория вычислений содержит число 20 и не содержит числа 8? 6. Исполнитель Калькулятор преобразует число на экране. У исполнителя есть две команды, которым присвоены номера: (1). Прибавить 1; (2). Умножить на 2. Программа для исполнителя Калькулятор – это последовательность команд. Сколько существует программ, для которых при исходном числе 1 результатом является число 28 и при этом траектория вычислений содержит число 25 и не содержит числа 10? 7. Исполнитель Калькулятор преобразует число на экране. У исполнителя есть две команды, которым присвоены номера: (1). Прибавить 1; (2). Умножить на 2. Программа для исполнителя Калькулятор – это последовательность команд. Сколько существует программ, для которых при исходном числе 2 результатом является число 34 и при этом траектория вычислений содержит число 10 и не содержит числа 28? 8. Исполнитель Калькулятор преобразует число на экране. У исполнителя есть две команды, которым присвоены номера: (1). Прибавить 1; (2). Умножить на 2. Программа для исполнителя Калькулятор – это последовательность команд. Сколько существует программ, для которых при исходном числе 2 результатом является число 29 и при этом траектория вычислений содержит число 14 и не содержит числа 25? 9. Исполнитель Калькулятор преобразует число на экране. У исполнителя есть две команды, которым присвоены номера: (1). Прибавить 1; (2). Прибавить 2. Программа для исполнителя Калькулятор – это последовательность команд. Сколько существует программ, для которых при исходном числе 1 результатом является число 13 и при этом траектория вычислений содержит число 7? 10. Исполнитель Калькулятор преобразует число на экране. У исполнителя есть две команды, которым присвоены номера: (1). Прибавить 1; (2). Умножить на 3. Программа для исполнителя Калькулятор – это последовательность команд. Сколько существует программ, для которых при исходном числе 4 результатом является число 50 и при этом траектория вычислений содержит число 6 и не содержит числа 12? Решите Только ответы
13
26
45
676
7677
Я насчёт последнего не уверен но вроде так