// PascalABC.NET 3.1, сборка 1230 от 27.04.2016 begin var n:=ReadInteger('n='); var a:=MatrixRandom(n,n,10,99); var s:=0; var k:=0; for var i:=0 to n-1 do begin for var j:=0 to n-1 do Print(a[i,j]); Writeln; if a[i,i].IsEven then begin s+=a[i,i]; Inc(k) end; end; if k>0 then Writeln('S=',s/k:0:2) else Writeln('На главной диагонали нет четных элементов') end.
1. Наука, изучающая законы и формы мышления, называется: Г) логика
2. Повествовательное предложение, в котором что-то утверждается или отрицается называется: В) высказывание
3. Константа, которая обозначается «1» в алгебре логики называется: В) истина
4. Какое из следующих высказываний являются истинным? В) II + VI = VIII (2 + 6 = 8, записанное при римских чисел)
5. Объединение двух высказываний в одно с союза «и» называется: Б) конъюнкция
6. Чему равно значение логического выражения (1v1)^(1v0)? А) 1 ((1 v 1) ^ (1 v 0) = 1 ^ 1 = 1)
7. Что такое логика? B) это наука о формах и законах человеческого мышления и, в частности, о законах доказательных рассуждений
8. Логической операцией не является: A) логическое деление
9. Объединение двух высказываний в одно с оборота «если..., то..» называется: Г) импликация
10. Таблица, содержащая все возможные значения логического выражения, называется: Б) таблица истинности
11. Даны три высказывания: А = (Наступила осень) В = (Мы учимся в колледже) С = (Мы решаем контрольную работу) Напишите в виде формулы высказывание: «Наступила осень, мы учимся в колледже и решаем контрольную работу» ABC
12. Придумайте ложное высказывание, соответствующее функции и постройте таблицу истинности для следующей функции: Х=А+ВС В ответе выписать комбинации А, В, С при которых Х – ложно. Например, если A = (Скопье – столица Черногории), B = (Скопье – столица Македонии) и C = (Скопье – столица Эфиопии), то X = A + BC соответствует ложному высказыванию "Скопье – столица Черногории или Македонии и Эфиопии". Таблица истинности: A B C X 0 0 0 0 0 0 1 0 0 1 0 0 – случай из примера 0 1 1 1 1 0 0 1 1 0 1 1 1 1 0 1 1 1 1 1 X ложно при (A, B, C) = (0, 0, 0), (0, 0, 1), (0, 1, 0).
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Pascal.Получите из слова «совершенствование» слова: 1.шествие 2.вершина 3.рост 4.варан 5.сорт 6.рисование
begin
var n:=ReadInteger('n=');
var a:=MatrixRandom(n,n,10,99);
var s:=0;
var k:=0;
for var i:=0 to n-1 do begin
for var j:=0 to n-1 do Print(a[i,j]);
Writeln;
if a[i,i].IsEven then begin s+=a[i,i]; Inc(k) end;
end;
if k>0 then Writeln('S=',s/k:0:2)
else Writeln('На главной диагонали нет четных элементов')
end.
Тестовое решение
n= 8
63 13 33 90 25 21 87 91
88 88 48 13 30 59 81 27
73 23 76 77 52 19 33 97
53 87 13 74 17 35 61 70
77 96 51 61 82 33 63 22
39 88 84 54 88 73 74 69
76 26 69 14 45 80 70 54
80 36 47 38 18 22 84 62
S=75.33