olartamonov6
?>

3.Составить программу поиска трехзначных чисел, которые при делении на 43 дают в остатке 27.ПИТОН

Информатика

Ответы

evsmorodina

for i in range(100,1000):

   if i % 43 == 27:

       print(i)


3.Составить программу поиска трехзначных чисел, которые при делении на 43 дают в остатке 27.ПИТОН
Komarovsergeysk

#include <iostream>

#include <vector>

#include <set>

#include <cmath>

using namespace std;

bool check(double a, double b, double c){

   return !(a >= b + c || b >= a + c || c >= b + c);

}

double square(double a, double b, double c){

   double p = (a+b+c)/2;

   return sqrt(p * (p-a) * (p-b) * (p-c));

}

bool is_palind(int k){

   string s = to_string(k);

   for(int i = 0; i < s.length() - i - 1; i++)

       if(s[i] != s[s.length()-i-1])

           return false;

   return true;

}

void solve1(){

   vector<double> lines(4);

   double ans = -1;

   for(auto &i : lines) cin >> i;

   for(int i = 0; i < 4; i++)

       for(int j = i + 1; j < 4; j++)

           for(int k = j + 1; j < 4; j++)

               if(check(lines[i],lines[j],lines[k]))

                   ans = max(ans,square(lines[i],lines[j], lines[k]));

   ans == -1 ? cout << "No solution" : cout << ans;

}

void solve2(){

   set<int> s;

   for(int i = 1000; i < 10000; i++)

       if(is_palind(i))

           s.insert(i);

   int n;

   cin >> n;

   s.find(n) != s.end() ? cout << n : cout << *upper_bound(s.begin(),s.end(),n);

}

vikapar2646
1) 1024 байт =1024 байт
1024 байт > 1000 байт
800 байт < 1024 байт
400 бит = 400 бит
8192 байта < 1024 байта
2) 64 бита=64*8 байт=512 байт
3) 64=2^6?   i=6 бит
4) 40 байт
5)11 Кб=11*1024*8 бит
11*1024*8=11264*i     i=(11*1024*8)/11264=8 бит
N=2^8=256
6) 32=2^5? 
i=5
7) N=16   i=4     N=256   i=8     
8/4=2 (в 2 раза)
8) N=16   i=4   k=50   
I=50*4=200 бит
9) N=256   i=8   k=30*70*5   
I=30*70*5*8=84000 бит
10) 1 Мб=1024*1024*8 бит
1/512 Мб=(1024*1024*8)/512=1024*16 бит
1024*16=2048*i        i=(1024*16)/2048=8 бит
N=2^i     
2^8=256
11) N=256   i=8   k=160*192
I=160*192*8 бит
I=(160*192*8)/(1024*8)=30 Кб

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

3.Составить программу поиска трехзначных чисел, которые при делении на 43 дают в остатке 27.ПИТОН
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

nchalov2
dvpered
osnovnoisklad3551
rn3ay8
mihailpolehin8
Суховодова599
langprint
kayrina
natalia-bokareva
jaksonj326
Александрович
ivanovmk1977
eeirikh
Fruktova Gazaryan