Задание: Написать программу на ЯПPyton: с клавиатуры вводится два целых числа. Если их разность кратна 3, то появляется надпись «Разность кратна 3», иначе появляется надпись «Разность не кратна 3»
print('Разность кратна трем' if (int(input()) - int(input())) % 3 == 0 else 'Разность не кратна трем')
e-liza-k
31.03.2022
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016 // Внимание! Если программа не работает, обновите версию!
begin var M:=ArrRandom(ReadInteger('x='),-50,50); M.Println; var pa:=M.Where(p->p>3).Average; Writeln('Среднее арифметическое чисел, превышающих 3: ',pa); var pm:=M.TakeLast(10).Max; Writeln('Максимум из десяти последних чисел: ',pm); var pp:=pm/pa; Writeln('Отношение двух найденных величин: ',pp); Writeln('Сформированный массив'); var C:=M.Where(p->p>pp).ToArray; C.Println end.
Пример x= 15 2 -44 30 49 -36 47 -38 -21 -50 3 -5 50 37 -8 -18 Среднее арифметическое чисел, превышающих 3: 42.6 Максимум из десяти последних чисел: 50 Отношение двух найденных величин: 1.17370892018779 Сформированный массив 2 30 49 47 3 50 37
damir
31.03.2022
Решение для одного-двух разных удаляемых символов
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016 // Внимание! Если программа не работает, обновите версию!
begin var s:=ReadlnString('>'); s:=s.Replace('.','').Replace(',',''); s.Println end.
Пример > Раз, два, три, четыре, пять. Вышел зайчик погулять. Раз два три четыре пять Вышел зайчик погулять
Решение, когда разных удаляемых символов может быть много
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016 // Внимание! Если программа не работает, обновите версию!
begin var s:=ReadlnString('>'); s:=s.Where(с->not(с in [',','.'])).JoinIntoString; s.Println end.
print('Разность кратна трем' if (int(input()) - int(input())) % 3 == 0 else 'Разность не кратна трем')