Поделитесь своими знаниями, ответьте на вопрос:
с решением Решение на языке Паскаль На обработку поступает натуральное число, не превышающее 109. Нужно написать программу, которая выводит на экран произведение цифр числа, которые делятся на 2 и на 4. Если в числе нет таких цифр, требуется на экран вывести «NO».
var N,digit,maxDigit: longint;
begin
readln(N);
maxDigit := N mod 10;
while N > 0 do
begin
digit := N mod 10;
if digit mod 3 = 0 then
if digit > maxDigit then
maxDigit := digit;
N := N div 10;
end;
if maxDigit = 0 then
writeln('NO')
else
writeln(maxDigit)
end.
Объяснение:
вроде так