Чечин-Павлова615
?>

не проблема :) Задание Изучите внешний вид системы программирования Турбо Паскаль. Общая структура программы на языке Паскаль: Рrogram ИМЯ..; {заголовок программы} Uses ...; {раздел описания модулей} Var ..; {раздел объявления переменных} ... Begin {начало исполнительной части программы} ... {последовательность ... операторов} End. {конец программы} Пример программы, которая осуществляет сложение двух чисел и выводит сумму на экран: Program Summa; Uses Crt;{Подключаем модуль Crt} Var number1, {переменная, в которой будет содержаться первое число} number2, {переменная, в которой будет содержаться второе число} rezult {переменная, в которой будет содержаться результат}: integer; {указывает тип целых чисел} Begin ClrScr;{Используем процедуру очистки экрана из модуля Crt} Write ('Введите первое число '); {Выводим на экран символы, записанные между апострофами} Readln (number1); {Введенное пользователем число считываем в переменную number1} Write ('Введите второе число '); {Выводим на экран символы, записанные между апострофами} Readln (number2); {Введенное пользователем число считываем в переменную number2} rezult := number1 + number2; {Находим сумму введенных чисел и присваиваем переменной rezult} Write ('Сумма чисел ', number1, ' и ', number2, ' равно ', rezult); {Выводим на экран строчку, содержащую ответ задачи} Readln;{Процедура задержки экрана) End. ответьте на во Какое назначение переменных number1, number2, rezult? 2. Что обозначает строка: number1, number2, rezult : integer; ? 3. Если присвоить переменным number1 и number2 соответственно значение 5 и 7, то какую строчку выдаст компьютер при исполнении последней процедуры Write? Запишите ее в отчет. 4. Переведите с английского языка слова: Write, Read. Как вы думаете, что должен делать операторы с таким названием? 5. Как вы понимаете запись: readln(number1); ? 6. Чему равно значение переменной rezult после выполнения оператора: rezult := number1 + number2; ? 1. Что делает оператор присваивания в этой программе? Задание ответьте на во Что такое среда программирования? 2. Опишите среду программирования Тurbo Pascal. 3. Как сохранить текст программы в Тurbo Pascal? 4. Какова структура программы на языке Pascal? 5. Как осуществить запуск программы? Задание № 5. Сделать вывод о проделанной практической работе.

Информатика

Ответы

nataliagoncharenko
Язык не указан, Default-Language это C. На нём и напишу.
1.
#include <stdio.h>
int main() {
    int n;
    scanf("%d", &n);
    if (n % 10 == 4 || n % 10 == 7 || n / 10 == 4 || n / 10 == 7)
        printf("YES\n");
    else
        printf("NO\n");
    return 0;
}
Для порядку скажу что на Perl это можно реализовать проще.
#!perl
%h { 4 => 0, 7 => 0};
<>;
if (exists $h{$_%10} || exists $h{$_/10}) {
    print "YES\n";
else {
    print "NO\n";
}
Но мы ушли от темы. Итак, 2. Тут всё ещё проще:
#include <stdio.h>
int main() {
    int n;
    scanf("%d", &n);
    if (!(n % 3))
        printf("Multiple of 3\n");
    else
        printf("Not multiple of 3\n");
    if (n % 10 == 3)
        printf("Ends by 3\n");
    else
        printf("Not ends by 3\n");
    return 0;
}
Тут более простой реализации на другом известном мне языке нету, так что приводить дополнительно ничего не буду.
strannaya2018
Я считаю, что развитие сети Интернет приведет к исчезновению традиционных медиа, так как эта сеть становится более доступной и пользоваться ей гораздо проще. Это легко доказать, взяв хотя бы промежуток времени совсем незначительный, например 2004 год - 2014 год. Что мы наблюдали в то время и что наблюдаем сейчас? Интернет уже, практически на 90%, вытеснил использование традиционных медиа. А, как известно, Интернет не перестает развиваться, и уже кратчайшие сроки традиционные медиа будут полностью замещены.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

не проблема :) Задание Изучите внешний вид системы программирования Турбо Паскаль. Общая структура программы на языке Паскаль: Рrogram ИМЯ..; {заголовок программы} Uses ...; {раздел описания модулей} Var ..; {раздел объявления переменных} ... Begin {начало исполнительной части программы} ... {последовательность ... операторов} End. {конец программы} Пример программы, которая осуществляет сложение двух чисел и выводит сумму на экран: Program Summa; Uses Crt;{Подключаем модуль Crt} Var number1, {переменная, в которой будет содержаться первое число} number2, {переменная, в которой будет содержаться второе число} rezult {переменная, в которой будет содержаться результат}: integer; {указывает тип целых чисел} Begin ClrScr;{Используем процедуру очистки экрана из модуля Crt} Write ('Введите первое число '); {Выводим на экран символы, записанные между апострофами} Readln (number1); {Введенное пользователем число считываем в переменную number1} Write ('Введите второе число '); {Выводим на экран символы, записанные между апострофами} Readln (number2); {Введенное пользователем число считываем в переменную number2} rezult := number1 + number2; {Находим сумму введенных чисел и присваиваем переменной rezult} Write ('Сумма чисел ', number1, ' и ', number2, ' равно ', rezult); {Выводим на экран строчку, содержащую ответ задачи} Readln;{Процедура задержки экрана) End. ответьте на во Какое назначение переменных number1, number2, rezult? 2. Что обозначает строка: number1, number2, rezult : integer; ? 3. Если присвоить переменным number1 и number2 соответственно значение 5 и 7, то какую строчку выдаст компьютер при исполнении последней процедуры Write? Запишите ее в отчет. 4. Переведите с английского языка слова: Write, Read. Как вы думаете, что должен делать операторы с таким названием? 5. Как вы понимаете запись: readln(number1); ? 6. Чему равно значение переменной rezult после выполнения оператора: rezult := number1 + number2; ? 1. Что делает оператор присваивания в этой программе? Задание ответьте на во Что такое среда программирования? 2. Опишите среду программирования Тurbo Pascal. 3. Как сохранить текст программы в Тurbo Pascal? 4. Какова структура программы на языке Pascal? 5. Как осуществить запуск программы? Задание № 5. Сделать вывод о проделанной практической работе.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

T91610933073266
gurman171
Катерина Телюкин925
Tatyanaaarzieva72
delo1005
annakorotaev3
ksvish2012
snow8646
Абубакр_Будаш
nsn-2012
Yevgeniya Bessonov
Альберт Луиза1595
lavorenn
m-zolotukhina2
Aleksandrova Zhanna1250