Сергеевич1726
?>

Есть три категории чисел: ‘*’, ‘+’, ‘-’. На вход программе подается число. Если число четное и положительное, вывести на консоль ‘*’, если число нечетное и положительное, вывести ‘+’, если число четное и отрицательное, вывести ‘-’. Во всех остальных случаях вывести на консоль сообщение “unknown category”.

Информатика

Ответы

Вячеслав

1 - True/False

2 - логическая операция, которая объединяет два высказывания в одно новое, которое будет являться истинным тогда и только тогда, когда оба исходных высказывания ложны.

3 - Конъюнкция

4 - X И Y И Z

5 - OR

6 - 1. Инверсия;

2. Конъюнкция;

3. Дизъюнкция;

4. Импликация;

5. Эквивалентность.

7 - логическая операция, которая преобразует исходное высказывание в новое, значение которого противоположно исходному.

8 - Импликация

9 - логическая операция, которая объединяет два высказывания в одно новое, которое будет являться истинным тогда и только тогда, когда оба исходных высказывания истинны

10 -  Конъюнкция

11 - ?

12 - ?

Объяснение:

vova00831

Проверяем в конструкторе значения на данные признаки, если мы получаем ошибку инициализации, то даем переменным нулевые значения, дабы избежать ошибок в других функция. (грубо говоря, чтобы вся программа не легла из-за конструктора, благодаря выводу текстового сообщения мы будем знать где конкретно ошибка)

#include <iostream>

#include <cmath>

class Progression {

private:

float first;

int second;

public:

Progression(float a0, int d) {

 if (a0 == round(a0)) {

  std::cout << "Инициализация первого члена прогрессии с конструктора не удалась, первый элемент не должен быть целыми числом!\n";

  this->first = 0;

 }

 else {

  this->first = a0;

  std::cout << "Инициализация первого члена прогрессии успешно!\n";

 }

 if (d < 0) {

  std::cout << "Инициализация разности прогрессии с конструктора не удалась, разность должна быть положительной!\n";

  this->second = 0;

 }

 else {

  this->second = d;

  std::cout << "Иницализация разности успешно!\n";

 }

}

float operator()(int j){

 return this->first + this->second * (j - 1);

}

};

signed main() {

setlocale(LC_ALL, "Rus");

float a;

int b;

std::cout << "Введите значение a0 и d: ";

std::cin >> a >> b;

Progression p1(a, b);

std::cout << p1(2);

return 0;

}


С++ ООП Очень вот мой код который считает арифметической прогрессию, но нужно чтобы первое значение

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Есть три категории чисел: ‘*’, ‘+’, ‘-’. На вход программе подается число. Если число четное и положительное, вывести на консоль ‘*’, если число нечетное и положительное, вывести ‘+’, если число четное и отрицательное, вывести ‘-’. Во всех остальных случаях вывести на консоль сообщение “unknown category”.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

mileva84
Vorotko814
sbraginets
Novikova Aleksandrovna
Болеславовна
sisychev
scorpion21c
Mikhailova
akakne86
Andrei-Shchukin
Mukhlaev-Olga
martinson
ryadovboxing
terehin863
Алёна Геннадьевна98