Александрович
?>

Задача № 1: Составить программу вычисления выражения 5 корень из х+у3-х/z-1/x+2y

Информатика

Ответы

Никита

const

 AOper: array [0..3] of string = ('+', '-', '*', '/');

var

 a, b, Oper: Integer;

 r: Real;

begin

 Randomize;    // инициализация датчика случайных чисел

 a := Random (1001);

 b := Random (1001);

 Oper := Random (4);

 case Oper of

 0: r := a + b;

 1: r := a - b;

 2: r := a * b;

 3:if b <> 0 then begin

     r := a / b;

   end else begin

     WriteLn ('Произошла ошибка при делении на ноль');

     Exit;

   end

 else r := -1;

 end;

 WriteLn (a);

 WriteLn (b);

 WriteLn (Aoper [Oper]);

 if (r >= 0) and (r - Trunc (r) = 0) then begin   // если в результате получилось положительное целое число

   WriteLn ('yes');

   WriteLn (r :6 :0);

 end else

   WriteLn (' no');

 ReadLn;

end.

Объяснение:

r - Trunc (r) // это выделение дробной части числа

Бурмистрова-Ирина660
1)Значение величины как и в информатике и математике одинаковы. Величина делится на Постоянные и Переменные.
1. Постоянной называется величина, значение которой не изменяется в процессе выполнения программы.
2. Переменной называется величина, значение которой изменяется в процессе выполнения программы.

2) Существуют три основных типа величины 1.Числовое 2.Символьный 3.Логический.

3) Программа присваивания записывается таким образом  := (В языке Pascal).

4) Программа ввода записывается таким образом  read();  или readln();-полностью readline();  (В языке Pascal).

5) 1.Программа вывода записывается таким образом  write('Любая надпись'); или writeln('Любая надпись'); полностью writeline('Любая надпись');     2. Программа write или writeln выводит канцоль или в окно вывода  то что ты написал в write или в writeln.
 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Задача № 1: Составить программу вычисления выражения 5 корень из х+у3-х/z-1/x+2y
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

lazarevaavrora
parolmm
Timurr007
zotcet7
ivanandrieiev1984268
Энверович
valeron7hair7
manu95957
inna-zub
Сергеевич1726
ekaterinapetrenko877529
Рогова Ольга1156
Yevgenevna
i7aster26
Манько_Панферов