?>
                
1) Напишите программу, которая получает два целых числа A и B (0 < A < B) и выводит квадраты всех натуральных чисел в интервале от A до B (на языке С++) Пример: Введите два целых числа: 10 12 10*10=100 11*11=121 12*12=144 2) Ввести натуральное число и найти сумму его цифр ( на языке С++) Пример: Введите натуральное число: 12345 Сумма цифр 15
              
              
              
                
Ответы
                
              
              
             
            
          
1) Получение квадратов всех натуральных чисел в заданном интервале:
```cpp
#include
using namespace std;
int main() {
int A, B;
cout << "Введите два целых числа: ";
cin >> A >> B;
for (int i = A; i <= B; i++) {
int square = i * i;
cout << i << "*" << i << "=" << square << endl;
}
return 0;
}
```
Объяснение:
- Мы объявляем две переменные `A` и `B`, чтобы хранить вводимые пользователем значения.
- Затем мы просим пользователя ввести два целых числа и сохраняем их в переменные `A` и `B`.
- Затем мы используем цикл `for`, чтобы пройти через все числа от `A` до `B`.
- Внутри цикла мы вычисляем квадрат каждого числа, умножая его самого на себя, и сохраняем результат в переменной `square`.
- На каждой итерации цикла мы выводим квадрат числа в формате `Число*Число=Квадрат`.
2) Нахождение суммы цифр натурального числа:
```cpp
#include
using namespace std;
int main() {
int num, digit, sum = 0;
cout << "Введите натуральное число: ";
cin >> num;
while (num > 0) {
digit = num % 10; // Получаем последнюю цифру числа
sum += digit; // Добавляем цифру к сумме
num /= 10; // Уменьшаем число, удаляя последнюю цифру
}
cout << "Сумма цифр " << sum << endl;
return 0;
}
```
Объяснение:
- Мы объявляем переменные `num`, `digit` и `sum`. `num` будет хранить вводимое пользователем натуральное число, `digit` будет хранить последнюю цифру числа на каждой итерации, а `sum` будет хранить сумму цифр числа.
- Запрашиваем у пользователя ввод натурального числа и сохраняем его в переменную `num`.
- Пока число `num` больше нуля, мы выполняем следующие действия:
- Делим число `num` на 10, чтобы получить последнюю цифру числа (остаток от деления).
- Добавляем полученную цифру к сумме `sum`.
- Уменьшаем число `num`, удаляя последнюю цифру.
- После завершения цикла выводим сумму цифр на экран.
Надеюсь, это поможет! Если у вас есть еще вопросы, не стесняйтесь задавать.