tokarevmax
?>

написать код на C#Трёхчлен a + bx + сy от двух переменных x и y однозначно определяется коэффициентами a, b и c. Написать программу, которая по заданным a, b и c выводит соответствующий трёхчлен, записанный с использованием алгебраических соглашений: коэффициент при члене, содержащем переменную, опускается, если его модуль равен единице; член, коэффициент при котором равен нулю, опускается (кроме случая, когда все коэффициенты равны нулю, тогда трехчлен состоит из одной цифры 0); знак "+" опускается, если он предшествует отрицательному коэффициенту; знак "+" опускается, если он стоит в начале выражения (так называемый унарный плюс); знак умножения между коэффициентом и переменной опускается.При этом запрещено менять местами члены.Входные данныеВо входном файле INPUT.TXT через пробел записаны целые коэффициенты a, b и с, каждое из которых не превосходит 30000 по абсолютной величине.Выходные данныеВыходной файл OUTPUT.TXT должен содержать трехчлен, записанный с использованием алгебраических соглашений.​

Информатика

Ответы

aguliaeva

1) Если изначальный массив НЕ дан, т.е необходимо его заполнить случайными числами

#include <iostream>

#include <cstdlib>

#include <ctime>

using namespace std;

void GetMaxAndMinIndex(int* data,int* MaxIndex,int* MinIndex) {

for (int i = 0; i < 200; ++i) {

 if (data[i] > data[i + 1]) {

  *MaxIndex = i;

 }

 if (data[i] < data[i + 1]) {

  *MinIndex = i;

 }

}

}

void SearchSrAr(int* data,int* MaxIndex,int* MinIndex) {

int tmpI = 0;

int TmpNum = 0;

for (int i = *MinIndex; i < *MaxIndex; ++i) {

 TmpNum = TmpNum + data[i];

 tmpI++;

}

double output = TmpNum / tmpI;

cout <<"Ваше число "<< output;

}

int main() {

setlocale(LC_ALL, "Russian");

int* data = new int[200];

int MaxIndex = 0, MinIndex = 100;

srand(time(NULL));

for (int i = 0; i < 200;++i) {

 data[i] = rand() % 100;

}

GetMaxAndMinIndex(data, &MaxIndex, &MinIndex);

SearchSrAr(data, &MaxIndex, &MinIndex);

delete[] data;

}

И если этот массив и его размер нам известны

#include <iostream>

#include <cstdlib>

#include <ctime>

using namespace std;

void GetMaxAndMinIndex(int* data,int* MaxIndex,int * n,int* MinIndex) {

for (int i = 0; i < *n; ++i) {

 if (data[i] > data[i + 1]) {

  *MaxIndex = i;

 }

 if (data[i] < data[i + 1]) {

  *MinIndex = i;

 }

}

}

void SearchSrAr(int* data,int* MaxIndex,int* MinIndex) {

int tmpI = 0;

int TmpNum = 0;

for (int i = *MinIndex; i < *MaxIndex; ++i) {

 TmpNum = TmpNum + data[i];

 tmpI++;

}

double output = TmpNum / tmpI;

cout <<"Ваше число "<< output;

}

int main() {

setlocale(LC_ALL, "Russian");

int n;

cout << "Введите количество чисел в массиве " << endl;

cin >> n;

int* data = new int[n];

int MaxIndex = 0, MinIndex = 100;

cout << "Введите ваш массив " << endl;

for (int i = 0; i < n; ++i) {

 cin >> data[i];

}

GetMaxAndMinIndex(data, &MaxIndex,&n, &MinIndex);

SearchSrAr(data, &MaxIndex, &MinIndex);

delete[] data;

}

Объяснение:

Код на с++

fixer2006

const

 N = 10;

var

 B: array[1..N+1] of integer;

 Sum, i, first_even_i: integer;

Begin

 WriteLn('Введите массив: ');

 For i := 1 to N do

   Read(B[i]);

 

 For i := 1 to N-1 do

   if (B[i+1] mod 2 <> 0) then

     B[i] := 0;

 

 For i := 1 to N do

   if (B[i] mod 2 = 0) then

   begin

     first_even_i := i;

     break;

   end;

 

 For i := N+1 downto first_even_i + 1 do

   B[i] := B[i-1];

 

 B[first_even_i] := 0;

 

 WriteLn('Среднее арифметическое всех элементов: ', Sum / (N + 1));

 WriteLn('Получившийся массив: ', B);

End.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

написать код на C#Трёхчлен a + bx + сy от двух переменных x и y однозначно определяется коэффициентами a, b и c. Написать программу, которая по заданным a, b и c выводит соответствующий трёхчлен, записанный с использованием алгебраических соглашений: коэффициент при члене, содержащем переменную, опускается, если его модуль равен единице; член, коэффициент при котором равен нулю, опускается (кроме случая, когда все коэффициенты равны нулю, тогда трехчлен состоит из одной цифры 0); знак "+" опускается, если он предшествует отрицательному коэффициенту; знак "+" опускается, если он стоит в начале выражения (так называемый унарный плюс); знак умножения между коэффициентом и переменной опускается.При этом запрещено менять местами члены.Входные данныеВо входном файле INPUT.TXT через пробел записаны целые коэффициенты a, b и с, каждое из которых не превосходит 30000 по абсолютной величине.Выходные данныеВыходной файл OUTPUT.TXT должен содержать трехчлен, записанный с использованием алгебраических соглашений.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

natakrechko
aureole6452
vadimkayunusov
dkedrin74038
tumanowivan2015509
Devaunka40
samoilovcoc
Анатольевна
Александрович784
Борисовна_Кашутина
spodobnyi
gbg231940
symkifm
Timurr007
al2nik2ol