denisovatat7
?>

решить задачки по с++, сама пыталась, но безуспешно. 1) Составить программу для вычисления суммы факториалов всех печатных чисел .Построить блок схему 2.)Составить программу для нахождения наибольшего общего деятеля четырёх натуральных чисел Построить блок схему. 3.)Заменить отрицательные элементы линейного массива их модулями , не пользуясь стандартной функцией вычисления модуля. Подсчитать количество произведённых замен. Построить блок схему.

Информатика

Ответы

titovass9

Объяснение:

Вредная информация-Реклама игр для детей старше 18 лет , реклама неприличных книг, разные посты в соц сетях которые являются пропагандой чего то плохого , азартные игры, помимо опасностей человеческих, есть еще опасности чисто технические. Заблудившись в сети очень легко заразить компьютер вредоносными программами. Кража паролей и прочей конфиденциальной информации, спам от вашего имени, хулиганство, вымогательство, угрозы

нежелательная информация. В интернете кроме орнографических сайтов существуют ресурсы, на которых в подробностях рассказывается о создании взрывных или поджигающих устройств, идеализируется такое понятие, как суіцид, употребление алкоголя, табака и запрещенных нарк@тических препаратов.

Vladimirovna Viktorovna
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

type
  CheckBalls=class
 
  private
   
    ad:array of real; // диаметры шариков
    ap:array of real; // веса шариков
    etD:=24.0; // эталонный диаметр
    derD:=2.0; // эталонное предельное отклонение
    etP:=74.0; // эталонный вес
    derP:=3.0; // эталонное предельное отклонение
   
    procedure CheckBall(m:integer);
    // проверка шарика с указанным номером
    begin
      Write('Шарик № ',m,': диаметр - ');
      if Abs(aD[m-1]-etD)<=derD then Write('норма')
      else Write('брак');
      Write(', вес - ');
      if Abs(aP[m-1]-etP)<=derP then Writeln('норма')
      else Writeln('брак')
    end;
  
 
  public
 
    constructor(ma,mp:array of real);
    begin
      ad:=Copy(ma);
      ap:=Copy(mp);
    end;
   
    procedure CheckAllBalls;
    begin
      for var i:=1 to ad.Length do CheckBall(i)
    end;
 
end;

begin
  var n:=120; // число шариков
  var a:=SeqRandom(n,200,280).Select(t->t/10).ToArray;
  var b:=SeqRandom(n,700,800).Select(t->t/10).ToArray;
  Writeln('Параметры шариков (диаметр,вес):');
  a.Zip(b,(p,q)->(p,q)).Println;
  Writeln('Результаты контроля:');
  var oL:=new CheckBalls(a,b);
  oL.CheckAllBalls
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

решить задачки по с++, сама пыталась, но безуспешно. 1) Составить программу для вычисления суммы факториалов всех печатных чисел .Построить блок схему 2.)Составить программу для нахождения наибольшего общего деятеля четырёх натуральных чисел Построить блок схему. 3.)Заменить отрицательные элементы линейного массива их модулями , не пользуясь стандартной функцией вычисления модуля. Подсчитать количество произведённых замен. Построить блок схему.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

basil69
fedserv
f-d-a-14
Tatianamir765654
gorod7
Мария
paninsv
Alyona
palosik7621
menametov
socofilesrus4
ti2107
zdanovich90764
info40
Мария-Кострыгина175