ivanovmk1977
?>

ЛЮДИ ДОБРЫЕ, КРАСАТУЛЕНЬКИ С ИНФОЙ Написать программу в паскале (тема строковый тип), которая запрашивает три строковые переменные: существительное, прилагательное и глагол, а затем выводит все варианты фраз с использованием введённых слов!

Информатика

Ответы

egcuzn86
Var
  a,r,rvp,rop:real;
begin
  Write('Введите сторону квадрата и радиус окружности: ');
  Readln(a,r);
  rvp:=a/2; rop:=a*sqrt(2)/2;
  if r<rvp then Writeln('Окружность расположена внутри вписанной')
  else
    if r=rvp then Writeln('Введен радиус вписанной окружности')
    else
      if r<rop then Writeln('Окружность расположена между вписанной и описанной')
      else
        if r=rop then Writeln('Введен радиус описанной окружности')
        else Writeln('Окружность расположена вне описанной')
end.

Тестовое решение:
Введите сторону квадрата и радиус окружности: 8 5
Окружность расположена между вписанной и описанной
ellyb106786
Var
  a,b,c,d,e,f,g,x1,x2:real;
begin
  Write('Введите значения e,f,g: '); Readln(e,f,g);
  a:=sqrt(abs(sqr(e)-g)/3); Writeln('a= ',a:0:5);
  b:=abs((e-f)/7); b:=b*sqr(b)-cos(g); Writeln('b= ',b:0:5);
  c:=f*sqr(f)-g/17; Writeln('c= ',c:0:5);
  d:=sqr(b)-4*a*c;
  if d<0 then Writeln('Действителных корней нет')
  else
    if d=0 then begin
      x1:=(-b-sqrt(d))/(2*a); x2:=x1;
      Writeln('x1=x2= ',x1:0:5)
    end
    else begin
      x1:=(-b-sqrt(d))/(2*a); x2:=(-b+sqrt(d))/(2*a);
      Writeln('x1= ',x1:0:5,', x2= ',x2:0:5)
    end
end.

Тестовое решение:
Введите значения e,f,g: 2 -3 -3
a= 1.52753
b= 1.35442
c= -26.82353
x1= -4.65721, x2= 3.77053

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

ЛЮДИ ДОБРЫЕ, КРАСАТУЛЕНЬКИ С ИНФОЙ Написать программу в паскале (тема строковый тип), которая запрашивает три строковые переменные: существительное, прилагательное и глагол, а затем выводит все варианты фраз с использованием введённых слов!
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

smnra219
margarita25061961
Палкина-Дроздова
yanva
Филиппович_Николаевич
Maloletkina-marina2
Татьяна1856
ksoboleva
tenvalerij
Alekseevich1012
natalia-shelkovich
seleznev1980
Vos-sv
zrv85
omigunova39