Anastasiya Yevseeva948
?>

Составить программу, которая вводит координаты точки (x, y) и определяет, попадает ли точка в заштрихованную область. (PascalABC)

Информатика

Ответы

Tatianarogozina1306

проверь, не застрял ли кардридж печати.

попробуй поменять режим печати на черно-белый или на цветной

самый очевидный, перезапустить принтер (хотя наверно попробывал думаю)

возможно дело в драйвере к принтеру, попробуй установить другой версии.

обычно кстати к принтерам делают софт с которого проще машиной, поищи мб есть.

если ранее небыло такой проблеммы при постоянном использовании, то перезапуск обычно решает проблемму.

еще как вариант( если печатаешь с пк а не на прямую), подключи принтер через другой порт usb

вроде все варианты перебрал, разве что кроме очевидной поломки внутренних частей принтера.а так все

kazan-ugoop36
//PascalABC.NET 3.1 сборка 1219
procedure PrintMatrix(a: array[,] of integer);
begin
    for var i := a.GetLowerBound(0) to a.GetUpperBound(0) do
    begin
        writeln;
        for var j := a.GetLowerBound(1) to a.GetUpperBound(1) do
            write(a[i, j], ' ');
    end;
    writeln;
end;

begin
    var a := MatrixRandom(9, 9, 10, 99);
    PrintMatrix(a);
    var i := (a.GetLowerBound(0) + a.GetUpperBound(0)) div 2 + (a.GetLowerBound(0) + a.GetUpperBound(0)) mod 2;
    var j := (a.GetLowerBound(1) + a.GetUpperBound(1)) div 2 + (a.GetLowerBound(1) + a.GetUpperBound(1)) mod 2;
    writeln('A[', i, ', ', j, '] = ', a[i, j]);
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу, которая вводит координаты точки (x, y) и определяет, попадает ли точка в заштрихованную область. (PascalABC)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

adminaa
Borg Fedak1162
vuyakovleva
nastya3213868
Alekseevna1811
suxoruchenkovm171
batalerka391
Vladimirovna Yevtodeva
metelkin7338
ольга1801
zuzman601
fednik3337923
JisesLove19955
Olybetezina1973
dimanov