o-lala88387
?>

Задание1: составить таблицу значений для функции у=ах²+в, где а=3 в=-5 на промежутке [0, 8] Найди ошибки в программе, исправь их В структуре программы ошибок нет! Program vesna; Var x, y, a, b: integer Begin а:=3; b:-5; x:=0; While x<=8 do Begin Y:= Writeln (‘x=’, x, ’ ‘, ’y=’, y:1); x:=x+1; end; readln; end. Задание2: составить программу на языке Паскаль по алгоритму Алгоритм решения линейного уравнения ах=в, где а и в произвольные вещественные числа алг линейноеуравнение арг а, в рез х, у нач если а≠0 то у:= «есть решение» х:=в/а иначе если в=0 то у:= «х-любое число» иначе у:= «решений нет» всё всё кон

Информатика

Ответы

Шапкина1531

В любой деятельности человек всегда придумывал и создавал самые разнообразные средства, при орудия труда. Все это облегчало труд, делало его производительнее, расширяло возможности людей. Известно, что история материального производства и мировой науки тесно связана с историей развития орудий труда.

Первые вс средства для работы с информацией появились много позже первых орудий материального труда. Историки утверждают, что расстояние во времени между появлением первых инструментов для физического труда (топор, ловушка для охоты) и инструментов для регистрации информационных образов (на камне, кости) составляет около миллиона лет!

Следовательно, почти 99% времени существования человека на Земле труд носил только материальный характер.

Уже говорилось о том, что информационную деятельность человека можно разделить на три составляющие: хранение, передачу и обработку. Долгое время средства информационного труда развивались отдельно по этим трем направлениям. 

Удачи!

olesyadeinega41
Пусть выбраны гирьки с массами M1, M2, ..., Mn и ими удалось массу X. 

Тогда имеет место равенство X = a1 * M1 + a2 * M2 + ... + an * Mn,
где ai = 0, если i-ая гирьке не участвовала в взвешиваниях, -1, если лежала на той же чаше весов, что и масса, которкю нужно отмерить, и +1, если на другой чаше весов. 

Каждый из коэффициентов принимает одно из трёх значений, тогда при гирек можно отмерить не более, чем 3^n различных масс. 3^3 < 40 + 1 < 3^4, значит, гирек нужно не менее четырёх. 

Докажем, что взяв гирьки с массами 1, 3, 9 и 27, можно отмерить любую массу от 1 до 40. Будем это делать по индукции, доказав, что при гирек 1, 3, 9, ..., 3^k можно отмерить любую массу от 1 до (3^k - 1)/2.

База индукции. При одной гирьки массой 1 действительно можно отмерить массу 1.
Переход. Пусть для k = k' всё доказано. Докажем и для k = k' + 1.
- Если нужно отмерить массу X <= (3^k' - 1)/2, то это можно сделать при гирек. 
- Пусть надо отмерить массу (3^k' - 1)/2 < X <= (3^(k' + 1) - 1)/2. Кладём на другую чашу весов гирьку массой 3^k'. Тогда остаётся нескомпенсированная масса |X - 3^k'| <= (3^k' - 1)/2, которую, по предположению, можно получить. Ура!

ответ. 1, 3, 9, 27.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Задание1: составить таблицу значений для функции у=ах²+в, где а=3 в=-5 на промежутке [0, 8] Найди ошибки в программе, исправь их В структуре программы ошибок нет! Program vesna; Var x, y, a, b: integer Begin а:=3; b:-5; x:=0; While x<=8 do Begin Y:= Writeln (‘x=’, x, ’ ‘, ’y=’, y:1); x:=x+1; end; readln; end. Задание2: составить программу на языке Паскаль по алгоритму Алгоритм решения линейного уравнения ах=в, где а и в произвольные вещественные числа алг линейноеуравнение арг а, в рез х, у нач если а≠0 то у:= «есть решение» х:=в/а иначе если в=0 то у:= «х-любое число» иначе у:= «решений нет» всё всё кон
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

best00
mikhisakov2017
ivan-chay19
Yuliya_Viktoriya316
lider123
xobby18
pwd10123869
Petrakova Ilyushin
Олимов Протопопова
marusyamr
Sofinskaya1185
Azarenkoff
krasnobaevdj3
shutovaa3471
egorsalnikov1997139