Voronov434
?>

Используя любой, компилятор языка программирования Pascal напишите программу.ПРОГРАММА- должна решать уравнение x^2:(x*4)-x:(x*2)Логика программы1.В блоке описания переменных описать переменную X. Так как в уравнение есть деление, значит нужно использовать вещественный тип данных; Описать переменную result для того, чтобы в неё поместить результат уравнения;2.Ввести значение переменной X с клавиатуры;3.В переменную result присвоить уравнение.ВАЖНО!Вы не можете написать в компьютере дробь так же, как в тетради. Всё необходимо писать линейно. Например:x:yэто выражение на языке Pascal можно описать только в линию, т.е

Информатика

Ответы

bezpalova2013
Составим программку:

uses Crt;
const n=20;
type Mas=array [1..n, 1..n] of integer;
var A: Mas;
    i,k, Sum: integer;
begin
ClrScr;
Sum:=0;
for i:=1 to  n do
  begin
  for k:=1 to n do
     begin
      if i>k then
             begin
                A[i,k]:=1;
                Sum:=Sum+A[i,k];
             end
             else
             begin
                A[i,k] :=-1;
                Sum:=Sum+A[i,k];
             end;
      Write(A[i,k]:3);
     end;
  WriteLn;
  end;
  WriteLn;
  WriteLn(' Sum = ',Sum);
ReadLn;
end.

Эта программа симметрично относительно главной диагонали заполняет массив единичками с плюсом или минусом и считает сумму диагональных элементов.
Если n=20, то Sum = -20
Если n = 100, то Sum = - 100
ПРАВИЛЬНЫЙ ОТВЕТ:      3) - 100
bhg50
Составим программку:

uses Crt;
const n=20;
type Mas=array [1..n, 1..n] of integer;
var A: Mas;
    i,k, Sum: integer;
begin
ClrScr;
Sum:=0;
for i:=1 to  n do
  begin
  for k:=1 to n do
     begin
      if i>k then
             begin
                A[i,k]:=1;
                Sum:=Sum+A[i,k];
             end
             else
             begin
                A[i,k] :=-1;
                Sum:=Sum+A[i,k];
             end;
      Write(A[i,k]:3);
     end;
  WriteLn;
  end;
  WriteLn;
  WriteLn(' Sum = ',Sum);
ReadLn;
end.

Эта программа симметрично относительно главной диагонали заполняет массив единичками с плюсом или минусом и считает сумму диагональных элементов.
Если n=20, то Sum = -20
Если n = 100, то Sum = - 100
ПРАВИЛЬНЫЙ ОТВЕТ:      3) - 100

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Используя любой, компилятор языка программирования Pascal напишите программу.ПРОГРАММА- должна решать уравнение x^2:(x*4)-x:(x*2)Логика программы1.В блоке описания переменных описать переменную X. Так как в уравнение есть деление, значит нужно использовать вещественный тип данных; Описать переменную result для того, чтобы в неё поместить результат уравнения;2.Ввести значение переменной X с клавиатуры;3.В переменную result присвоить уравнение.ВАЖНО!Вы не можете написать в компьютере дробь так же, как в тетради. Всё необходимо писать линейно. Например:x:yэто выражение на языке Pascal можно описать только в линию, т.е
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

valerii-borisovich550
muravlev2702
Sacharov84
Ruslan374
Drugov_Vladimirovna
zmlavra
kareeva
Vitproficosmetics
stepanova-natalie
Polina780
Vs1377
stratocasterr34
ngoncharov573
svetlanam81
taanaami75
▲