masum-2011687
?>

PascalABC Выбрать любую из формул со скриншота (только одну) и составить программу которая будет работать на базе выбранной формулы

Информатика

Ответы

Шаленко
1 вариант

номер 1

Саша- Самойлов
Володя- Левин
Миша- Петриков (т.к только хозяин дома достанет гербарий из своего шкафа)
Юра- Богачёв

номер 2

переливаем 2 литра в 2-ух литровую банку из 6-ти литровой (1 переливание)
(получилось и у той и у другой мёда по 3 литра)
Из двух литровой доливаем литр, который вмещается в 4-ёх литровую банку (2 переливание)
последний литр из 2-ух литровой переливаем в 6ти литровую (3 переливания)

почему-то решилось за 3 переливания

номер 3

2,4,8,10,20,22,44,46...

Прибавление 2, умножение на 2, прибавление 2 и так далее

3,6,12,15,30, 33...

Прибавление 3, умножение на 2, прибавление 3 и т.д

1,3,4,12,13, 39, 40, 120, 121...

Умножение на 3, прибавление 1, умножение на 3 и т.д

Второй вариант решается аналогично
solonataly5
// PascalABC.NET 3.2, сборка 1401 от 14.03.2017
// Внимание! Если программа не работает, обновите версию!

1. Решение без проверки вводимых данных

begin
  var a,b:integer;
  Read(a,b);
  var P:=ArrFill(30,0);
  for var i:=a-1 to b-1 do P[i]:=2;
  P.Println
end.

Пример
2 10
0 2 2 2 2 2 2 2 2 2 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

2. Решение с контролем ввода

begin
  var a:=ReadInteger('Введите a от 1 до 30:');
  if a<1 then begin Writeln('Неверно'); Exit end;
  var b:=ReadInteger('Введите b от '+a.ToString+' до 30:');
  if (b<a) or (b>30) then begin Writeln('Неверно'); Exit end;
  var P:=ArrFill(30,0);
  for var i:=a-1 to b-1 do P[i]:=2;
  P.Println
end.

Пример
Введите a от 1 до 30: 2
Введите b от 2 до 30: 10
0 2 2 2 2 2 2 2 2 2 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

PascalABC Выбрать любую из формул со скриншота (только одну) и составить программу которая будет работать на базе выбранной формулы
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

vadim1140
Стадник620
mariavayda88734
vik-2202
yuliyastatsenko3894
bogdanovaoksa
Evelina Mariya
b3dllam
Yeroshkina411
Lugovoi
info2471
Сергеевич1907
Алексеевич620
laplena1982750
dilbaryan76