Aleksandrovna-Marina
?>

написать программу на языке С++, ставлю :Начав тренировки, спортсмен пробежал М км. Каждый день он увеличивал норму на Р% нормы предыдущего дня. В какой день спортсмен впервые пробежит М км?

Информатика

Ответы

Чубкова1290
//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
const
  m = 10;

var
  t: array[1..m] of integer;
  i, n, nm, sm: integer;

begin
  //Заполняем массив сл.числами и подсчитываем
  //количество элементов и среднее арифметическое
  //согласно условию задачи
  for i := 1 to m do
  begin
    t[i] := random(-20, 20);write(t[i]:4);
    if (i > 1) and (i <= m) then
      if t[i] > t[i - 1] then n := n + 1
      else if t[i] < t[i - 1] then begin
        sm := sm + t[i];nm := nm + 1;
      end;
  end;
  writeln;
  writeln('число элементов больших предыдущего = ', n);
  writeln('ср. арифметическое элементов меньших предыдущего = ', sm / nm);  
 
end.

Тестовое решение:
    6  13  19   8 -19 -11 -20 -15 -19 -13
число элементов, больших предыдущего = 5
среднее арифметическое элементов, меньших предыдущего = -12.5
kisa-luba
// PascalABC.NET 3.1, сборка 1218 от 12.04.2016
begin
  var m,n:integer;
  Write('Количество строк и столбцов матрицы: ');
  Read(n,m);
  var a:=MatrixRandom(n,m,10,99);
  for var i:=0 to n-1 do begin
    for var j:=0 to m-1 do Print(a[i,j]);
    Writeln
    end;
  var p:=ReadInteger('Введите число Р:');
  var b:array of integer;
  SetLength(b,4*m);
  var k:=0;
  for var i:=n-p to n-1 do
    for var j:=0 to m-1 do
      if a[i,j] mod 4=0 then begin
        b[k]:=a[i,j]; Inc(k)
        end;
  SetLength(b,k);
  b.Print
end.

Тестовое решение:
Количество строк и столбцов матрицы: 6 8
67 70 68 72 38 72 96 38
49 75 24 55 72 63 21 40
72 12 60 22 74 30 13 45
22 45 39 24 35 97 64 31
76 62 15 94 56 28 31 13
41 67 75 37 67 13 25 20
Введите число Р: 4
72 12 60 24 64 76 56 28 20

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

написать программу на языке С++, ставлю :Начав тренировки, спортсмен пробежал М км. Каждый день он увеличивал норму на Р% нормы предыдущего дня. В какой день спортсмен впервые пробежит М км?
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

milenaochirova01017424
Koshkina Alekseevna
md-masya
Viktorovna_Yurevna
elvini857
Кононова-БЕСКРОВНАЯ
Mashkov-Daniil1764
Александрович
Elenazhukovafashion7
larinafashion829
Голубева1440
karpachevamarina
Александрович784
shneider1969
anadtacia03108988
▲