ivnivas2008
?>

Надо написать программу на языке паскаль по блок схеме в ссылке всё указанно https://yadi.sk/i/uRBDVjPxeRd-aw

Информатика

Ответы

Vyacheslavovich-Gubanov
Задание 1:
Развернутая форма числа - представление числа в виде суммы каждого разряда числа.

4563 = 4 × 10^3 + 5 × 10^2 + 6 × 10^1 + 3 × 10^0

100101 = 1 × 2^5 + 0 ×2^4 + 0 ×2^3 + 1 ×2^2 + 0 ×2^1 + 1 ×2^0

AC6 = 10 ×16^2 + 12 ×16^1 + 6 × 16^0

Задание 2:

1001010, 112, 4А

Задание 3:

1)

11001101011+1110000101=100111110000
101011-10011=11000
1011х101=101100+1011=110111

2)

+564
  234

1020


Получилось: 564+234 = 1020

-652
 465

 165


Получилось: 652-465 = 165

3)

+DF45
 128A

F1CF


Получилось: DF45+128A = F1CF

-92D4
 11AE

8126


Получилось: 92D4-11AE = 8126



jablokov
#include <iostream>
#include <algorithm>
using namespace std;

int main()
{
    long long int n{ 0 }, z{ 0 };
    while (cin >> n) {
        size_t ans[120];
        for (; n != 0; n = n / 10) {
            int tmp = n % 10;
            if (n / 10 != 0 || (n / 10 == 0 && n != 9)) { 
                tmp = min(tmp, 9 - tmp); 
            }
            ans[z++] = tmp;
        }
        for (int i = z - 1; i >= 0; i--) {
            cout << ans[i];
        }
        cout << endl;
    }
    return 0;
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Надо написать программу на языке паскаль по блок схеме в ссылке всё указанно https://yadi.sk/i/uRBDVjPxeRd-aw
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

snip99
nv6634
T91610933073266
Ryazanova1575
Щербаков33
sv-rud
Pirogovskii695
bellaalya13862
sorokinae
Давид-Александр
Olegovna Volkov
ivanpetrovichru1801
Рожков Зейдан460
Александровна
v-shevlyakov7992