Напишите программу, которая вводит натуральное число (не более 1000000000) и опре-деляет, сколько его цифр равны 1: Введите натуральное число: 10010 Единиц: 2
// PascalABC.NET 3.3, сборка 1611 от 06.01.2018 // Внимание! Если программа не работает, обновите версию!
begin var a:=ArrRandom(20,2,5);Write('Оценки за диктант: ');a.Println; Writeln('Двоек: ', a.Where(t-> t = 2).Count); Writeln('Троек: ', a.Where(t-> t = 3).Count); Writeln('Четверок: ', a.Where(t-> t = 4).Count); Writeln('Пятерок: ', a.Where(t-> t = 5).Count); Writeln('Средний за диктант: ', a.Average:0:2); end.
Пример: Оценки за диктант: 4 3 2 3 5 3 3 2 5 2 3 5 4 3 3 4 2 2 3 2 Двоек: 6 Троек: 8 Четверок: 3 Пятерок: 3 Средний за диктант: 3.15
upmoskovskiy
21.05.2020
Program spos; uses crt; var numb:array [1..100] of byte; // для последовательности чисел i,f:integer; //счетчик и переменная в качестве флага begin randomize; f:=0; for i:=1 to 100 do numb[i]:=random(101);// задает последовательность
for i:=1 to 100 do begin write(',',numb[i]); // вывод на экран последовательность(можно удалить) if (numb[i]=77)then f:=1; // в случае удачной проверки f:=1, в противном останется 0 end; if f=0 then writeln('Yes') else writeln('No');
end.
program spos; uses crt; var numb:array [1..100] of byte; // для последовательности чисел i,f:integer; //счетчик и переменная в качестве флага begin randomize; f:=0; for i:=1 to 100 do begin numb[i]:=random(101);// задает последовательность write(' ',numb[i]);//вывод на экран, можно удалить end; writeln; i:=0; repeat i:=i+1; if (numb[i]=77)then f:=1; // в случае удачной проверки f:=1, в противном останется 0 until i<100; if f=0 then writeln('Yes') else writeln('No');
end.
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Напишите программу, которая вводит натуральное число (не более 1000000000) и опре-деляет, сколько его цифр равны 1: Введите натуральное число: 10010 Единиц: 2
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(20,2,5);Write('Оценки за диктант: ');a.Println;
Writeln('Двоек: ', a.Where(t-> t = 2).Count);
Writeln('Троек: ', a.Where(t-> t = 3).Count);
Writeln('Четверок: ', a.Where(t-> t = 4).Count);
Writeln('Пятерок: ', a.Where(t-> t = 5).Count);
Writeln('Средний за диктант: ', a.Average:0:2);
end.
Пример:
Оценки за диктант: 4 3 2 3 5 3 3 2 5 2 3 5 4 3 3 4 2 2 3 2
Двоек: 6
Троек: 8
Четверок: 3
Пятерок: 3
Средний за диктант: 3.15