Поделитесь своими знаниями, ответьте на вопрос:
Программа такая: есть завод, на котором производят ручки и запаковывают их в коробки. Он производит определенное количество ручек P, в одну коробку B помещается K ручек, остаток ручек O кладется в последнюю коробку L. Например, если завод произвел 100 ручек, а в коробку помещается 8 ручек, то всего будет 12 полных коробок, а в последней неполной коробке будет 4 ручки. Напишите программу, при запуске которой пользователь вводит количество произведенных ручек и количество ручек в коробке, а программа выдает количество полученных полных коробок и количество ручек в последней неполной коробке очень нужно
#include <cstdio>
#include <cmath>
using namespace std;
int main()
{
int a, b, c;
cin>>a>>b>>c;
if ((a + b < c) || (a + c < b) || (b + c < a))
{
cout<<"Не треугольник";
return 0;
}
if ((a * a + b * b == c * c) || (a * a + c * c == b * b)|| (c * c + b * b == a * a))
{
cout<<"Прямоугольный";
return 0;
}
if ((a * a + b * b > c * c) || (a * a + c * c > b * b)|| (c * c + b * b > a * a)) cout<<"Остроугольный";
else
cout<<"Тупоугольный"; }