magnit-expo
?>

РЕБЯТ Я НЕ РАЗБИРАЮСЬ, АЛГОРИТМИКА, ЧЕРТЕЖНИЕ, КТО РАЗБИРАЕТСЯ ЗАДАНИЕ В ФАЙЛЕ1.задание Выделите повторяющийся элемент, напишите процедуру для его рисования и составьте программу рисования ряда предметов2. Выделите рисование повторяющегося элемента в качестве про процедуры и Составьте программу рисования картинки внесите изменения в программу чтобы получилось 10 предметов

Информатика

Ответы

marusyamr

Объяснение:

1.

a = input("Введите через запятую значения элементов массива (2,3,6...): ").split(",")

new_array = []

for thing in a:

   new_array.append(int(thing) * 2)

print(new_array)

2.

a = input("Введите через запятую значения элементов массива (2,3,6...): ").split(",")

new_array = []

last_elem = int(a.pop())

counter = 0

for thing in a:

   if counter == 0:

       new_array.append(int(thing))

       counter += 1

   else:

       new_array.append(int(thing) * 5)

new_array.append(last_elem)

print(new_array)

3.

a = input("Введите через запятую значения элементов массива (2,3,6...): ").split(",")

part = int(len(a) / 2)

new_array = []

for thing in a[:part]:

   new_array.append(int(thing) + 1)

for thing in a[part:]:

   new_array.append(int(thing) * 2)

print(new_array)

4.

a = input("Введите через запятую значения элементов массива (2,3,6...): ").split(",")

print(sum([int(number) for number in a]) / len(a))

5.

import random

numbers = range(-2, 3)

random_array = random.sample(numbers, random.randint(1, 4))

positive = [numb for numb in random_array if int(numb) > 0]

print(sum(positive))

6.

import random

numberss = range(2, 11)

numbers = random.sample(numberss, random.randint(1, 9))

d = {"Чётные": 0, "Нечётные": 0}

for thing in numbers:

   if int(thing) % 2 == 0:

       d["Чётные"] += 1

   else:

       d["Нечётные"] += 1

print(f"Масив: {numbers}")

print(", ".join([f"{v}: {d[v]}" for v in d]))

7. Не сильно понял задачу, можно объяснить по-подробнее?)

makitra08

Объяснение:

1.

a = input("Введите через запятую значения элементов массива (2,3,6...): ").split(",")

new_array = []

for thing in a:

   new_array.append(int(thing) * 2)

print(new_array)

2.

a = input("Введите через запятую значения элементов массива (2,3,6...): ").split(",")

new_array = []

last_elem = int(a.pop())

counter = 0

for thing in a:

   if counter == 0:

       new_array.append(int(thing))

       counter += 1

   else:

       new_array.append(int(thing) * 5)

new_array.append(last_elem)

print(new_array)

3.

a = input("Введите через запятую значения элементов массива (2,3,6...): ").split(",")

part = int(len(a) / 2)

new_array = []

for thing in a[:part]:

   new_array.append(int(thing) + 1)

for thing in a[part:]:

   new_array.append(int(thing) * 2)

print(new_array)

4.

a = input("Введите через запятую значения элементов массива (2,3,6...): ").split(",")

print(sum([int(number) for number in a]) / len(a))

5.

import random

numbers = range(-2, 3)

random_array = random.sample(numbers, random.randint(1, 4))

positive = [numb for numb in random_array if int(numb) > 0]

print(sum(positive))

6.

import random

numberss = range(2, 11)

numbers = random.sample(numberss, random.randint(1, 9))

d = {"Чётные": 0, "Нечётные": 0}

for thing in numbers:

   if int(thing) % 2 == 0:

       d["Чётные"] += 1

   else:

       d["Нечётные"] += 1

print(f"Масив: {numbers}")

print(", ".join([f"{v}: {d[v]}" for v in d]))

7. Не сильно понял задачу, можно объяснить по-подробнее?)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

РЕБЯТ Я НЕ РАЗБИРАЮСЬ, АЛГОРИТМИКА, ЧЕРТЕЖНИЕ, КТО РАЗБИРАЕТСЯ ЗАДАНИЕ В ФАЙЛЕ1.задание Выделите повторяющийся элемент, напишите процедуру для его рисования и составьте программу рисования ряда предметов2. Выделите рисование повторяющегося элемента в качестве про процедуры и Составьте программу рисования картинки внесите изменения в программу чтобы получилось 10 предметов
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Anastasiya
buslavgroupe
Ulianev77
vovkiv7864
Бражинскене_Алексей
DmitrievnaVera
iuv61
verynzik66525
buleckovd8724
lighturist
olgakuz00261
armentamada1906
latoyan817
Mikuspavel2
Герасименко