mouse-0211fsb3509
?>

Дописать програму Составить программу, которая бросать случайные числа из интервала от 10 до 50 пока не выпадетзаданное с клавиатуры число А (10<=A<=50 Указать количество «бросков» до совпадения.Дописать програму var x, count, y:integer;begin writeln('Задумайие и введите число X (10<=x<=50)'); readln(x); y:=count:=здесь пропущена строка begin y:=random(41)+10; count:= writeln('Бросок №', count, ': y=', y); end; writeln; writeln('Количество бросков до совпадения ', count)end

Информатика

Ответы

angelina-uj1350
ответ:

var

   x, count, y:integer;

begin

   writeln('Задумайие и введите число X (10<=x<=50)');

   readln(x);

   y:=0;

   count:=0;

   while x<>y do

   begin

       y:=random(41)+10;

       count:=count+1;

       writeln('Бросок №',count,': y=',y);

   end;

   writeln;

   writeln('Количество бросков до совпадения ', count)

end.

egcuzn86
В windows Seven (SP1)

Рабочий стол — это главная область экрана, которая появляется после включения компьютера и входа в операционную систему Windows. Подобно поверхности обычного стола, она служит рабочей поверхностью. Запущенные программы и открытые папки появляются на рабочем столе. На рабочий стол можно помещать различные объекты, например файлы и папки, и выстраивать их в удобном порядке.Определение рабочего стола иногда расширяют, включая в него панель задач. Панель задач располагается у нижнего края экрана. На панели задач отображаются значки запущенных программ, позволяющих переключаться между ними. Она также содержит кнопку «Пуск» , которой можно воспользоваться для доступа к программам, папкам и параметрам компьютера.
Значки рабочего стола
Значки — это маленькие рисунки, обозначающие программы, файлы, папки и другие объекты. При первом запуске Windows на рабочем столе имеется как минимум один значок: корзина (подробно см. ниже). Возможно, изготовитель компьютера добавил на рабочий стол и другие значки. Ниже показано несколько примеров значков рабочего стола.
Примеры значков рабочего стола. Двойной щелчок значка на рабочем столе запускает или открывает объект, который он представляет.Добавление и удаление значков на рабочем столеЗначки, появляющиеся на рабочем столе, можно выбирать, добавляя и удаляя их в любое время. Некоторые пользователи предпочитают чистый, незагроможденный рабочий стол с небольшим количеством значков или вовсе без них. Другие размещают на рабочих столах десятки значков для быстрого доступа к часто используемым программам, файлам и папкам.Для упрощения доступа с рабочего стола можно создать ярлыки избранных файлов и программ. Ярлык — это значок, представляющий ссылку на объект, а не сам объект. Двойной щелчок ярлыка открывает объект. При удалении ярлыка удаляется только ярлык, но не исходный объект. Ярлык можно узнать по стрелке на его значке.

Значок файла (слева) и ярлык (справа). 
Добавление ярлыка на рабочий стол
Найдите объект, для которого необходимо создать ярлык.Щелкните правой кнопкой мыши объект, выберите Отправить и Рабочий стол (создать ярлык). На рабочем столе появится ярлык.
Добавление или удаление стандарт. значк. на раб. стол
К стандартным относятся значки рабочего стола для компьютера, личной папки пользователя, корзины и панели управления.Щелкните правой кнопкой пустую область рабочего стола и выберите Настройка.В левой области выберите Изменить значки рабочего стола.В Значки рабочего стола установите флажок каждого значка, добавляемого на рабочий стол, снимите флажки удаляемых и щелкните кнопку ОК.Перемещение файла из папки на рабочий стол
Откройте папку с файлом.Перетащите этот файл на рабочий стол.Удаление значка с раб. столаЩелкните значок правой кнопкой мыши и выберите Удалить. При удалении ярлыка удаляется только ярлык, исходный объект не удаляется.Изменение расположения значковWindows располагает значки столбцами у левого края рабочего стола. Но пользователь может изменить это расположение. Переместить значок можно путем его перетаскивания в новое место на рабочем столе.Кроме того, Windows может автоматически изменить порядок размещения значков. Щелкните правой кнопкой мыши пустую область рабочего стола, выберите Вид и Упорядочить значки автоматически. Windows разместит значки в левом верхнем углу и зафиксирует их положение. Для отмены запрета перемещения значков снова выберитеУпорядочить значки автоматически и снимите флажок для этого пункта.ПримечанияПо умолчанию Windows располагает значки на равном расстоянии один от другого, на невидимой сетке. Чтобы разместить значки ближе друг к другу или иметь возможность более точно задавать их местоположение, отключите сетку. Щелкните правой кнопкой мыши пустую область рабочего стола, выберите Вид и снимите флажок Выровнять значки по сетке. Чтобы включить сетку, повторите эти действия.Выделение нескольких значковЧтобы переместить или удалить одновременно группу значков, сначала необходимо их выделить. Щелкните пустую область рабочего стола и, не отпуская кнопку, перемещайте указатель. Обведите выделяемые значки прямоугольной рамкой. Отпустите кнопку мыши. Теперь выделенные значки можно переместить или удалить целой группой.
Выделите несколько значков рабочего стола, обведя их прямоугольной рамкой. Скрытие значков рабочего стола. Чтобы временно скрыть все значки на рабочем столе, не удаляя их, щелкните правой кнопкой мыши пустую область рабочего стола, выберите Вид и снимите флажок Отображать значки рабочего стола. Теперь значки на рабочем столе не отображаются. Чтобы вернуть их на экран, снова установите флажок Отображать значки рабочего стола.КорзинаУдаление файла или папки происходит не сразу — сначала они помещаются в корзину. Это удобно, так как удаленный объект может понадобиться позже, и его можно вернуть.

Пустая корзина (слева) и полная (справа)Если удаленные объекты больше не понадобятся, корзину можно очистить. Данные объекты будут окончательно удалены, а дисковое пространство, занимаемое ими, освободится.
uvarovig
Количество всевозможных программ 2^4 = 16
Перечислим их:
1111 =>  4+4+4+4 = 16
1112 =>  4+4+4-3 = 9
1121 =>  4+4-3+4 = 9
1122 =>  4+4-3-3 = 2
1211 =>  4-3+4+4 = 9
1212 =>  4-3+4-3 = 2
1221 =>  4-3-3+4 = 2
1222 =>  4-3-3-3 = -5
2111 => -3+4+4+4 = 9
2112 => -3+4+4-3 = 2
2121 => -3+4-3+4 = 2
2122 => -3+4-3-3 = -5
2211 => -3-3+4+4 = 2
2212 => -3-3+4-3 = -5
2221 => -3-3-3+4 = -5
2222 => -3-3-3-3 = -12

Перечислим полученные результаты с разными числами(одинаковые выводить не будем)
16
9
2
-5
-12

ответ: Таких чисел будет 5(пять)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дописать програму Составить программу, которая бросать случайные числа из интервала от 10 до 50 пока не выпадетзаданное с клавиатуры число А (10<=A<=50 Указать количество «бросков» до совпадения.Дописать програму var x, count, y:integer;begin writeln('Задумайие и введите число X (10<=x<=50)'); readln(x); y:=count:=здесь пропущена строка begin y:=random(41)+10; count:= writeln('Бросок №', count, ': y=', y); end; writeln; writeln('Количество бросков до совпадения ', count)end
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

NarekAlekseevich779
Дубровская571
ski89439
qwerty
mustaevdmitry397
Михайлов
olg14855767
Shurshilina850
apromovich1
nikv568734
Попова1271
silantyevevgeny
filternovo
oaved2018
nickname0091