borodin
?>

На вход программы подается количество вводимых чисел, а затем сами числа. Определить сколько вводимых чисел кратных 13. Вывести количество этих чисел. 2) На вход программы подается количество вводимых чисел, а затем сами числа. Числа положительные, не превышающие 100. Определить максимальное число в последовательности. Вывести это число.

Информатика

Ответы

Рафаэль633

1)

var

 a,i,count:integer;

begin

 readln(a);

 count:=0;

 for i:=1 to a do  

   begin

     readln(a);

     if a mod 13 = 0 then

       inc(count);

   end;

 writeln('Count: ',count);

end.

2)

var

 a,i,max:integer;

begin

 readln(a);

 for i:=1 to a do  

   begin

     repeat

       readln(a);

       if a>100 then

         writeln('Error.Repeat');

     until a<=100;

     if i = 1 then

       max:=a

         else

           if max < a then

             max:=a;

   end;

 writeln('Max: ',max);

end.

Dmitrievna405
Загадки:в этом заведении 
              все перебывали
              двоечники,гении
              отметки получали
              учились здесь артисты
              певцы,артиллеристы
              сюда хожу и я,
              и вы,мои друзья(школа)
    
              что же за предмет такой,
              девчонки и мальчишки?
              для каждого он-дорогой
              что это  (записная книжка)
              
              через поле и лесок подается голосок
              он бежит по проводам-
              скажешь здесь а слышно там (телефон)
manager-3
1. а) При каких значениях числа S Паша может выиграть в один ход? 
ответ:
       * при 12<=S<=28 Паша увеличивает количество камней в 3 раза и выигрывает в 1 ход
       ** при S=34 и S=35 Паша увеличивает количество на 2 камня и выигрывает в 1 ход

б) У кого из игроков есть выигрышная стратегия при S = 28, 30, 32? 
Опишите выигрышные стратегии для этих случаев. 
       28: у Паши: П*3=84 - победа Паши
       30: у Паши: П+2=32 В+2=34 П+2=36 Победа Паши
       32: у Вали: П+2=34 В+2=36 Победа Вали

2. У кого из игроков есть выигрышная стратегия при S = 10, 8? 
Опишите соответствующие выигрышные стратегии. 
       10: у Вали: П*3=30 В+2=32 П+2=34 В+2=36 - Победа Вали
                          П+2=12 В*3=36 - победа Вали
        8: у Паши: П+2=10 В+2=12 П*3=36 -  Победа Паши
                                       В*3=30 П+2=32 В+2=34 П+2=36 -  Победа Паши
                                                                  В*3=96 -  Победа Паши   
    
3. У кого из игроков есть выигрышная стратегия при S = 6?
       6: у Вали

Постройте дерево всех партий, возможных при этой выигрышной стратегии (в виде рисунка или таблицы). На рёбрах дерева указывайте, кто делает ход, в узлах – количество камней в позиции
       см. фото


Два игрока, паша и валя, играют в следующую игру. перед игроками лежит куча камней. игроки ходят по

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

На вход программы подается количество вводимых чисел, а затем сами числа. Определить сколько вводимых чисел кратных 13. Вывести количество этих чисел. 2) На вход программы подается количество вводимых чисел, а затем сами числа. Числа положительные, не превышающие 100. Определить максимальное число в последовательности. Вывести это число.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

garunkhachatryan
rytikovabs
ragimovelshad
Boyaris
Любовь-Волков1205
langprint
anovikovsr
info8
vikashop269
Иванович-Васильевна1153
mzubenko6
Александровна-Васильевна
Vyacheslavovich-Gubanov
NatalyaAlekseevich1644
almihanika435