varvara-kulkova
?>

Составьте программу для вычерчивания прямоугольника со сторонами 2 и 4 единичных отрезка, стороны которого параллельны осям координат и начертите его использовать Чертежник

Информатика

Ответы

Андреевна-Арзуманян1109

Непонятно, что за "надписи".

Предположим, что

1. "бабушка попросила"

2. "взяла лукошко"

3. "подошла к кусту"

4. "сорвала ягоду"

5. "сварили варенье"

тогда логика задачи будет следующей

 

бабушка попросила

Если Маша согласилась тогда

      взяла лукошко

      подошла к кусту

      Если куст с ягодами Тогда

          Пока (на кусте есть ягоды) и (лукошко пустое) Цикл

                  сорвала ягоду

          КонецЦикла

      КонецЕсли

      сварили варенье

КонецЕсли

 

В принципе, если несколько кустов, нужен цикл обхода по кустам пока не наполнится лукошко.

Larisa Bulgakova

Я бы написал по другому

 

Program vozvedenie_v_stepen;

var a,b:integer;

begin

writeln ('Введите число, которое будем возводить в степень');

readln (a);

writeln ('Введите число, обозначающее степень, в которую будем возводить');

readln (b);

Writeln (a,' в степени ',b,' = ',exp(b*ln(a))); 

end. 

 

Извиняюсь за неправильный ответ. Не увидел, что вам нужно с циклом. Тогда лучше так...

 

Program vozvedenie_v_stepen;
var a,b,c,d:integer;
begin
writeln ( 'Введите число, которое будем возводить в степень' );
readln (a);
c:=a;
writeln ( 'Введите число, обозначающее степень, в которую будем возводить');
readln (b);
for d:= 2 to b do
a:=a*c;
if b=0 then
writeln(1)
else
writeln (c,' в степени ',b,' = ',a);
end. 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу для вычерчивания прямоугольника со сторонами 2 и 4 единичных отрезка, стороны которого параллельны осям координат и начертите его использовать Чертежник
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ehrik-ch
alena
sokolowskayaa
gudachaa1480
masamosijcuk140244
gabbro19975650
gardenstreet5
мария Кузив1393
zrs-546
Андрееевич787
DmitrievnaVera
Svetlana191
Morozova-Starikov
mpityk
gusinica23