milaudina
?>

Напишите программу, которая получает 3 целых числа и определяет сколько среди них одинаковых. паскаль 8 класс

Информатика

Ответы

dimon198808744
Var a,b,c:integer;
begin.
writeln('a, b, c:');
readln(a,b,c);
if (a=b)and(b=c)
 then writeln(3)
 else if (a=b)or(a=c)or(b=c) then writeln(2)
                             else writeln(0);
end.

Пример:
a, b, c:
1 2 1.
2.
rinata542
// PascalABC.NET 3.0, сборка 1157 от 02.02.2016
begin
  var a:array[1..20] of integer;
  Randomize;
  for var i:=1 to 20 do a[i]:=Random(-50,50); a.Println;
  var b:=Range(2,20,2).Select(i->a[i]);
  Writeln('Элементы с четными индексами по возрастанию');
  b.Sorted.Println;
  Writeln('Элементы с четными индексами по убыванию');
  b.SortedDescending.Println;
end.

Тестовое решение:
-15 46 -34 -3 43 16 -17 -28 -19 12 -28 -11 48 -12 -1 33 -37 9 6 -40
Элементы с четными индексами по возрастанию
-40 -28 -12 -11 -3 9 12 16 33 46
Элементы с четными индексами по убыванию
46 33 16 12 9 -3 -11 -12 -28 -40
Татьяна
//1. Переборный алгоритм Евклида (цикл repeat)

var a, b, с: integer; 

begin

  write('Введите два числа: ');

  readln(a, b);

  if a < b then с := a + 1 else с := b + 1;

repeat с := с - 1

  until (a mod с = 0) and (b mod с = 0);

  write('NOD = ', с)

end.

 

//2. Алгоритм с вычитанием (цикл while)

var  a, b: integer;

begin

  write('a = ');

  readln(a);

  write('b = ');

  readln(b);

  while a <> b do

    if a > b then

      a := a - b

    else

      b := b - a;

  writeln('NOD = ', a);

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая получает 3 целых числа и определяет сколько среди них одинаковых. паскаль 8 класс
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

tatarinova-51
kodim4
yaudo47
oxy03214428
Абубакр_Будаш
Tatyanaaarzieva72
beaevgen711
mishamedbrat
petrowich076813
art-03857
sanyaborisov910067
Алексей Ксения
rytikovabs
tashovairina
Игоревна
▲