Нужно составить программу, которая запрашивает количество касс, выполняет моделирование работы банка в течение рабочего дня и выводит долю “плохих” минут в Pascal ABC.
Будьте людьми это хорошему человеку обуздать информатику.
Египтян2004
15.04.2022
// Написать программу: Гречу, массой х г, рассыпают по пакетам: по а г в каждый. //Пакетов может быть неограниченное количество. Сколько гречи будет в //последнем заполненном пакете?
var x,a : longword; begin writeln ('Введите общую массу гречи, в граммах'); readln (x); writeln ('Введите массу насыпаемой в пакет гречи, в граммах'); readln (a); writeln ('полных пакетов будет ',(x div a)); if (x mod a)=0 then writeln ('В последнем насыпанном пакете будет ',a,' грамм гречи') else writeln ('В последнем насыпанном пакете будет ',(x mod a),' грамм гречи'); end.
ii090758
15.04.2022
1. Если считать, что в русском алфавите 32 буквы (без Ё), то по формуле мощности алфавита получаем: N = 2^I, 32= 2^5;I = 5. (Количество информации в одном символе) Значит в слове ИНФОРМАТИКА (11 букв) содержится 5 * 11 = 55 бит. 2. Не совсем корректные условия, не дано, сколько бит занимает 1 символ. Примем те же условия, что и в следующей задаче: 8 бит = 1 байт. Тогда Количество символов = 305 * 38 * 49 = 567910 Количество информации = 567910 * 1 байт = 554,6 кБ 3. На одной странице 40*64 = 2560 символов. Это занимает 2560 байт. 20 кБ = 20480 Б. Количество страниц = 20480 / 2560 = 8 стр.
Будьте людьми это хорошему человеку обуздать информатику.