bogdanovaoksa
?>

Написать программу, инвертирующее байтовое число. Т.е. число 25 превратит в -25. Число -127 превратит в 127.

Информатика

Ответы

dumpler

С++

#include <iostream>

int main() {

 char a = 25, b = -127;

 a = ~a;

 a++;

 b = ~b;

 b++;  

 printf("%d %d", a, b);

}

Версия с вводом числа (терминал)

#include <iostream>

int main() {

 char a;

 std::cout << "Type your num: ";

 std::cin >> a;

 a = ~a;

 a++;

 printf("Your inverse num: %d", a);

}

Aleksei Biketova
Отношение объектов и множеств.

Отношение - это взаимная связь, в которой находятся какие либо объекты.

Виды отношений:
1) Объект-объект
2) Объект-множество
3) Множество-множество

Отношения множеств можно легко показать с кругов Эйлера.

Виды отношений между множествами:
1) Множества пересекаются.
Это значит,что у множеств есть общие единицы. Например, множество людей, говорящих на башкирском и множество людей, говорящих на русском. Но есть люди, говорящие на двух языках. Это и есть пересечение множеств.
2) Множества не пересекаются.
Это значит,что у множеств нет одинаковых частей, они не пересекаются.
3) Множества равны
Это значит, что элементы в двух мнлжествах одинаковы
4) Подмножество
Бывает так, что в одном множестве есть ещё одно множество. Оно называется подмножество. Например: множество людей, а у него подмножество дети.
natura-domA90
Современный компьютер может обрабатывать числовую, текстовую, графическую, звуковую и видео информацию. Все эти виды информации в компьютере предоставлены в двоичном коде, т.е. используется алфавит мощностью всего два символа 0 и 1. Связано это с тем, что удобно представлять информацию в виде последовательности электрических импульсов: импульс  отсутствует- 0, импульс есть -1.Такое кодирование принято называть двоичным, а сами логические последовательности нулей и единиц- машинным языком.
Каждая цифра  машинного двоичного кода несет количество информации равное одному биту.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, инвертирующее байтовое число. Т.е. число 25 превратит в -25. Число -127 превратит в 127.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

danceplusru
kris5009646
sveta740450
st-op767840
Любовь
dianabuchkina
admin8808
masha812
alexluu33
lelikrom2202
megaromeo
okovyrova1
oyudina
VSpivak3122
Mukhina1811