gallush9
?>

Напишите программу на языке Паскаль для решения следующей задачи: Дан квадрат со стороной a и равносторонний треугольник со стороной b. Чей периметр меньше?

Информатика

Ответы

mv7095

var a, b: integer;

begin

 readln(a, b);

 a:= a*4;

 b:=b*3;

 if a > b then writeln('Периметр квадрата больше')

 else writeln('Периметр треугольника больше');

end.

bas7572513

1.

1) 4*24*1000*16 ≈ 3*2^19 (бит/с)

2) 900 Мбайт=9*25*4*2^23 бит =9*25*2^25 бит

3) (9*25*2^25) / (3*2^19) = 3*25*2^6 (c) = 75*64 (c) =75*64/60 (мин)= 80(мин)                                

ответ  80 мин

2.

1)  640*480=(5*2^7)*(15*2^5)=5*15*2^12 пикселей

2) 240 Кбайт=15*2^4 *2^13 бит=15*2^17 бит

3) (15*2^17) / (5*15*2^13) = 2^4 / 5  бит =3,2 бит = 3 бит - 1 пиксель

4) 2^3=8 цветов                ответ 8 цветов

3.

1) 80 *0,7=56 Мбайт - cжатый файл

 80 Мбайт =5*2^4 *2^23 бит=5*2^27 бит

  56 Мбайт=7*2^26 бит

2)  5*2^27 / 2^22 = 5*2^5 (с) = 160 секунд - время несжатого файла

3)  7*2^26 / 2^22 =7*2^4 (c) = 112 (c)

4) 23(c)+12(c)+112(c)= 147 (c) - время сжатого файла

5) 160-147=13 (с)    ответ передача сжатого файла быстрее на 13 с

AleksandrIvanovich1273
Будем рассматривать восьмеричное число как набор двоичных триад
8) Наименьшее четырехзначное восьмеричное число - это 1000₈.
1000₈ = 1 000 000 000₂, но у нас нулей может быть только три, поэтому оставляем самые левые нули, чтобы число оставалось минимально возможным: 1 000 111 111₂ = 1077₈
9) Наибольшее четырехзначное восьмеричное число - это
7777₈ = 111 111 111 111₂, но у нас только четыре единицы и мы оставим их слева, чтобы число оставалось максимальным:
111 100 000 000₂ = 7400₈
10)Наибольшее четырехзначное восьмеричное число - это
7777₈ = 111 111 111 111₂, но у нас только четыре нуля и мы запишем их справа, чтобы число оставалось максимальным:
111 111 110 000₂ = 7760₈

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу на языке Паскаль для решения следующей задачи: Дан квадрат со стороной a и равносторонний треугольник со стороной b. Чей периметр меньше?
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

oslopovavera
Karpova
salesrawtogo
guujuu
d111180
Валиахметова
Tsibrova
semenovakotya577
info-mosbalkon
whitewhit90
mstapottery
Олегович Паутова
Valerii276
Давид-Александр
snopok66
▲