didizain
?>

РЕБЯТА, УМОЛЯЮ НУЖНО ОЧЕНЬ ОЧЕНЬ Напишите программу, которая в последовательности натуральных чисел определяет сумму всехчисел, кратных 3 и оканчивающихся на 9. Программа получает на вход натуральные числа, количествовведённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончанияввода, не входит в последовательность Количество чисел не превышает 100. Введённые числа непревышают 300. Программа должна вывести одно число: сумму всех чисел, кратных 3 иоканчивающихся на 9.Пример работы программы:Входные данные Выходные данные162956939048​

Информатика

Ответы

Lenok33lenok89

Я комментарием пометил ошибку

type point=record

x,y:real;

end;

var a:array[1..3] of point;

i,j: integer;

z: point;

c: real;

begin

writeln('Координаты вершин');

readln(a[1].x,a[1].y,a[2].x,a[2].y,a[3].x,a[3].y);

//отсортируем по убыванию y

for i:=1 to 2 do

for j:=i+1 to 3 do

if a[i].y>a[j].y then

begin

z:=a[j];

a[j]:=a[i];

a[i]:=z;

end;

//выбираем первую точку

if a[2].x a[2].x then    // Ошибка, здесь ничего не сравнивается

begin

z:=a[3];

a[3]:=a[2];

a[2]:=z;

end;

for i:=1 to 3 do begin

c:=sqrt(a[i].x*a[i].x + a[i].y*a[i].y);

writeln ('Расстояние от начала координат',' ',c);

end;

readln

end.

severbykova

дуктом питания, упоминания о ней можно найти в древних летописях, и только после XVIII столетия она уступила свою популярность завезенному из Америки картофелю. Растение репа – ценный овощной и лекарственный продукт. Ее можно запекать, варить, фаршировать, добавлять в салаты. Репа обладает антисептическим, противовоспалительным, мочегонным, обезболивающим и ранозаживляющим действием. Она повышает аппетит, усиливает перистальтику кишечника, ускоряет процесс усвоения пищи организмом.

Объяснение:

баллы хочу

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

РЕБЯТА, УМОЛЯЮ НУЖНО ОЧЕНЬ ОЧЕНЬ Напишите программу, которая в последовательности натуральных чисел определяет сумму всехчисел, кратных 3 и оканчивающихся на 9. Программа получает на вход натуральные числа, количествовведённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончанияввода, не входит в последовательность Количество чисел не превышает 100. Введённые числа непревышают 300. Программа должна вывести одно число: сумму всех чисел, кратных 3 иоканчивающихся на 9.Пример работы программы:Входные данные Выходные данные162956939048​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

impuls20125948
sanhimki47
ksen1280
hobpack
k-serga1
ibird777
Наталья_Васищев
vahmistrova
beaevgen711
arammejlumyan
Boss5519
info32
mstrshulz
skyey
oksanakv1950