Анна1169
?>

Написать программу нахождения суммы цифр отрицательного трехзначного числа -123 Программа плутон

Информатика

Ответы

Григорьевич915
Вся информация, которую обрабатывает компьютер должна быть представлена двоичным кодом с двух цифр 0 и 1. Эти два символа принято называть двоичными цифрами или битами. С двух цифр 0 и 1 можно закодировать любое сообщение. Это явилось причиной того, что в компьютере обязательно должно быть организованно два важных процесса: кодирование и декодирование.Кодирование – преобразование входной информации в форму, воспринимаемую компьютером, т.е. двоичный код.Декодирование – преобразование данных из двоичного кода в форму, понятную человеку.С точки зрения технической реализации использование двоичной системы счисления для кодирования информации оказалось намного более простым, чем применение других
kirieskamod262
1.

program raf105;

var a,b,c:integer;

begin

write('Введите 3 числа: ');

readln(a,b,c);

if (a<b) and (a<c)

 then writeln('Произведение 2 наибольших чисел: ',b*c);

if (b<a) and (b<c)

 then writeln('Произведение 2 наибольших чисел: ',a*c);

if (c<b) and (c<a)

 then writeln('Произведение 2 наибольших чисел: ',b*a);

end.

2.а)

program raf105;

var a,i,b:integer;

begin

write('Введите число: ');

readln(a);

for i:=1 to a do

 if ((a mod i)=0) and ((i mod 2)<>0)

   then b:= b+i;

writeln('Сумма нечётных делителей введённого числа: ',b);

end.

б)

program raf105;

var a,a2,i,j,b:integer;

begin

write('Введите меньшее число: ');

readln(a);

write('Введите большее число: ');

readln(a2);

for j:=a to a2 do

begin

 for i:=1 to j do

   if ((j mod i)=0) and ((i mod 2)<>0)

     then b:= b+i;

writeln('Сумма нечётных делителей числа ',j,' равна: ',b);

b:= 0;

end;

end.

Язык программирования PascalABC

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу нахождения суммы цифр отрицательного трехзначного числа -123 Программа плутон
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Yuliya701
stratocasterr34
slazurnaya
helenya
Yevgenevich1150
alislisa191
olimp201325
vodolaz8384
d5806252
Playintim405374
asemchenko
Kochetova92
andreyduborezz2913
zolotayaoxana1982
Lavka2017