innavinogradova1385
?>

У исполнителя Бета две команды, которым присвоены номера: 1. прибавь b 2. умножь на 3 (b - неизвестное натуральное число) Выполняя первую из них, Бета увеличивает это число на 3. Программа для исполнителя Альфа - это последовательность номеров команд. Известно, что программа 21212 переводит число 3 в число 225. Определите значение b.

Информатика

Ответы

Zakharov Lilit

Значение b Программа для исполнителя Альфа - это последовательность номеров команд. Известно, что программа 9090!!!

Varagyan1728

При определении значений подобных функций переменная y вычисляется по-разному (по разным формулам) в зависимости от значения x.

Такие задачи решаются с конструкции условного оператора if - else. Поскольку в данном случае мы имеем три условия (x > 0, x = 0 и x < 0), то потребуется использование еще вложенной конструкции if - else, т. к. в языке Pascal нет оператора множественного ветвления (оператор case в данном случае не подходит).

В языке программирования Паскаль (да и в других тоже) желательно вложенные конструкции if - else помещать во внешнюю ветку else, а не if. Так проще не запутаться.

Таким образом, алгоритм вычисления значения функции может быть таким:

Если x > 0, то у = x - 2

Иначе (ниже идет вложенная конструкция)

Если x = 0, то y = 0

Иначе y = |x|.

В последнем пункте можно опустить оператор if с проверкой, что x < 0, так как если ход выполнения программы дошел до этого пункта, то x уже другим быть и не может (варианты, когда он больше или равен нулю, уже были исключены).

Для определения модуля (абсолютного значения) переменной можно использовать встроенную функцию abs() языка Pascal. В данном случае можно обойтись и без нее: поскольку уже известно, что x отрицателен, то, чтобы получить положительное число (модуль), нужно его умножить на -1.

var

   x, y: integer;

 

begin

   write ('x = ');

   readln (x);

 

   if x > 0 then

       y := x - 2

   else

       if x = 0 then

           y := 0

       else

           y := abs(x);

 

   writeln ('y = ', y);

 

end.

Объяснение:

Linichuk
Запрещяется:

трогать разъемы соединительных кабелей;

прикасаться к питающим проводам и устройствам заземления;

прикасаться к экрану и к тыльной стороне монитора;

включать и отключать аппаратуру без указания преподавателя;

класть диск, книги, тетради на монитор и клавиатуру;

работать во влажной одежде и влажными руками.

Перед началом работы:

Убедитесь в отсутствии видимых повреждений рабочего места; сядьте так, чтобы линия взора приходилась в центр экрана, чтобы, не наклоняясь, пользоваться клавиатурой и воспринимать передаваемую на экран монитора информацию.

Разместите на столе тетрадь, учебное пособие так, чтобы они не мешали работе на ЭВМ.
Внимательно слушайте объяснения учителя и старайтесь понять цель и последовательность действий; в случае необходимости обращайтесь к преподавателю.

Хорошо разберитесь в особенностях, применяемых в работе аппаратов.

Начинайте работу только по указанию преподавателя «Приступить к работе».

Во время работы:

Строго выполняйте все указанные выше правила, а также текущие указания учителя.

Следите за исправностью аппаратуры и немедленно прекращайте работу при появлении необычного звука или самопроизвольного отключения аппаратуры. Немедленно докладывайте об этом преподавателю.

Плавно нажимайте на клавиши, не допуская резких ударов.

Не пользуйтесь клавиатурой, если не подключено напряжение.

Работайте на клавиатуре чистыми руками.

Никогда не пытайтесь самостоятельно устранять неисправности в работе аппаратуры.

Вы должны хорошо знать и грамотно выполнять эти правила, точно следовать указаниям преподавателя, чтобы:

а) избежать несчастных случаев;

б) успешно овладеть знаниями, умениями, навыками;

в) сберечь вычислительную технику и оборудование.

Правильная посадка при работе за компьютером.

Сидеть нужно на расстоянии 60—70 см от монитора, допустимо не менее 50 см, соблюдая правильную посадку, не сутулясь, не наклоняясь;
Экран монитора не должен находиться выше уровня глаз.

Ноги должны стоять на полу, согнутыми в коленках под прямым углом. Они не должны свисать со стула.

Лучше всего использовать специальные стулья для работы за компьютером.

Руки в локтях должны быть согнуты под прямым углом.
В топ если

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

У исполнителя Бета две команды, которым присвоены номера: 1. прибавь b 2. умножь на 3 (b - неизвестное натуральное число) Выполняя первую из них, Бета увеличивает это число на 3. Программа для исполнителя Альфа - это последовательность номеров команд. Известно, что программа 21212 переводит число 3 в число 225. Определите значение b.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Косоногов Иосифовна
ag-modul
strager338
Васильевич Валерьевна
Алёна Геннадьевна98
ksyusatom19
dilanarthur27
Юлия-Ольга1313
Сергеевна_Юрикович
kep92
Gera8061
vitaliy
buriginast5
Abespal
alaevluka77