Сергеевна_Юрикович
?>

Напишите программу, которая вводит число и если число положительное, то увеличивает его на 10.если отрицательное, то возводит в квадрат.

Информатика

Ответы

timsch12
По моему где то еще в начальной школе было разложение обычного десятичного числа по , типа: 155367=100000+50000+5000+300+60+7 уже наверно в средней школе это усложнилось и вас возможно заставляли делать так: на самом деле это называется что то вроде представления числа в стандартном виде если все что мы расписали умножить и сложить обратно мы разумеется получим исходное число в нашем примере основание системы счисления 10 а теперь если подобные манипуляции произвести с любым другим числом записаным в другой системе счисления но при этом заменить десятку на основание системы счисления  ( а это может быть какоеугодно число) то мы получим числозаписаное в обычном виде. возможно тебе не понятны термины навроде системы счисления? на всякий случай(грубо говоря): сист счисл-я - это правила по которым мы записываем числа или сколько цифр используем для записи чисел например десятичная с.с.: используется 10 цифр, 0 1 2 3 4 5 6 7 8 9 а в двоичной мы все числа записываем с двух цифр, единицы и нуля, это происходит примерно так: 0=0 1=1 2=10 3=11 4=100 5=101 6= 110 и так далее(возможно несколько сумбурно и не понятно но я честно пытаюсь донести все простым языком) основанием системы счисления называется количество цифр которое используется для записи чисел ps кстати это основание как правило записывается в низу после числа, и возможно вы перепутали его со степенью)) вроде теорию постаралась обьяснить, а теперь само 10000101= = =133 //упс здесь действительно 133, я ранее ошиблась чуток)) 00011001=  =16+8+1=25 1110011= =64+32+16+0+0+2+1=80+35=115 11,11=
aivanova
Уверен, что формула в условии написана неверно, но уж как var   a,b,c: real; begin   write('введите a,b,c: '); read(a,b,c);   writeln('результат: ',max(a,a+b)+max(a,b+c)/1+max(max(a+b*c,1),5)) end. тестовое решение: введите a,b,c: -3 5.5 4 результат: 31 а вот так, на мой взгляд, должно быть: var   a,b,c: real; begin   write('введите a,b,c: '); read(a,b,c);   writeln('результат: ',(max(a,a+b)+max(a,b+c))/(1+max(a+b*c,1. end. тестовое решение: введите a,b,c: -3 5.5 4 результат: 0.6

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая вводит число и если число положительное, то увеличивает его на 10.если отрицательное, то возводит в квадрат.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Tatianamir765654
margo929
Некрасова-И
soa8690
Apresov
contact
optima3559
rsksnb
ale99791308
pereverzev
dima-pashkovec
Сергеевич1726
Александр734
barnkim
memmedovallahverdi0239