zaravshan20134
?>

В программе «:=» обозначает оператор присваивания; «+», «-», «*», «/», «div», «mod» — соответственно операции сложения, вычитания, умножения, деления, деления нацело и остатка от деления. Правила выполнения операций и порядок действий соответствуют правилам арифметики. Определите значение переменной y после выполнения алгоритма

Информатика

Ответы

narkimry134

51

Объяснение:

p = 19

y = 18

p =y*2 + p = 18 * 2 + 19 = 55

y = 1*(p - y mod 7) - так как "p" у нас поменялось подставлять будем новое значение

y =1 * (55 -( (18 / 7) остаток)) = 55 - 4 = 51

AkimovaI1608
//Боль
//Pascal ABC.NET 3.1 сборка 1219

Var
 f:text;
 max,min,p:real;
 maxn,minn,n,i:integer;
 ar:array of real;
 s:string;
begin
max:=real.MinValue;
min:=real.MaxValue;
n:=0;
 assign(f,'text.txt');
 reset(f);
 while not(Eof(f)) do
  begin
   read(f,p);
   inc(n);
   setlength(ar,n);
   ar[n-1]:=p;
   if ar[n-1]>max then
    begin
     max:=ar[n-1];
     maxn:=n-1;
    end;
   if ar[n-1]<min then
    begin
     min:=ar[n-1];
     minn:=n-1;
    end;
  end;
 close(f);
swap(ar[minn],ar[maxn]);
for i:=0 to n-1 do
if i<>n-1 then s:=s+floattostr(ar[i])+' '
else
s:=s+floattostr(ar[i]);
rewrite(f);
write(f,s);
close(f);
end.

Пример содержимого text.txt:
0 -2.1 1.1
Пример содержимого text.txt после работы программы:
0 1.1 -2.1
Александра Викторович531

Информацию следует считать особым видом ресурса, при этом имеется ввиду толкование "ресурса" как запаса неких знаний материальных предметов или энергетических, структурных или каких-либо других характеристик предмета. В отличие от ресурсов, связанных с материальными предметами, информационные ресурсы являются неистощимыми и предполагают существенно иные методы воспроизведения и обновления, чем материальные ресурсы. Рассмотрим некоторый набор свойств информации:

1) запоминаемость; 

2) передаваемость; 

3) преобразуемость; 

4) воспроизводимость; 

5) стираемость. 

   Свойство запоминаемости - одно из самых важных. Запоминаемую информацию будем называть макроскопической (имея ввиду масштабы запоминающей ячейки и время запоминания). Именно с макроскопической информацией мы имеем дело в реальной практике. 

   Передаваемость информации с каналов связи (в том числе с помехами) хорошо исследована в рамках теории информации К.Шеннона. В данном случае имеется ввиду несколько иной аспект информации к копированию, т.е. к тому, что она может быть "запомнена" другой макроскопической системой и при этом останется тождественной самой себе. Очевидно, что количество информации не должно возрастать при копировании. 

   Воспроизводимость информации тесно связана с ее передаваемостью и не является ее независимым базовым свойством. Если передаваемость означает, что не следует считать существенными отношения между частями системы, между которыми передается информация, то воспроизводимость характеризует неиссякаемость и неистощимость информации, т.е. что при копировании информация остается тождественной самой себе. 

   Фундаментальное свойство информации - преобразуемость. Оно означает, что информация может менять и форму своего существования. Копируемость есть разновидность преобразования информации, при котором ее количество не меняется. В общем случае количество информации в процессах преобразования меняется, но возрастать не может. Свойство стираемости информации также не является независимым. Оно связано с таким преобразованием информации (передачей), при котором ее количество уменьшается и становится равным нулю.

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

В программе «:=» обозначает оператор присваивания; «+», «-», «*», «/», «div», «mod» — соответственно операции сложения, вычитания, умножения, деления, деления нацело и остатка от деления. Правила выполнения операций и порядок действий соответствуют правилам арифметики. Определите значение переменной y после выполнения алгоритма
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

shmanm26
Сергеевна
BlenDer екі өлшемді графика
Korobeinikov-Yulich23
kuz-vlad21
alesia1986
prohorovalena
Aleksandrovich_Mitoyan1138
dimoni86
DVOct33
tagirova1
triumfmodern
mayorovmisc6
yuliyaminullina
Aleksei Aleksandrovna649
Okunev1034
▲