st-op767840
?>

Ниже на пяти языках программирования записана рекурсивная функция (процедура) F. procedure F(n: integer); begin write(n); if n > 2 then begin F(n − 1); F(n − 2); F(n − 3) end end; Что выведет программа при вызове F(4)? В ответе запишите последовательность выведенных цифр слитно (без пробелов

Информатика

Ответы

Olybetezina1973
Var s:string;
n,k,i:integer;
begin
for n:=1 to 2 do
 begin
 writeln('Введите строку ',n,':');
 readln(s);
 k:=0;
 for i:=1 to length(s) do
  begin
  case s[i] of
   '[': k:=k+1;
   ']': k:=k-1;
   end;
  end;
 if k=0 
 then writeln('В строке ',s,' количество [ и ] одинаково')
 else writeln('В строке ',s,' количество [ и ] не одинаково');
 end;
end.

Пример:
Введите строку 1:
c:=a[imax,j]; a[imax,j]:=a[imin,j]; a[imin,j]:=c
В строке c:=a[imax,j]; a[imax,j]:=a[imin,j]; a[imin,j]:=c количество [ и ] одинаково
Введите строку 2:
Просто [ пример ]] со [[ скобками
В строке Просто [ пример ]] со [[ скобками количество [ и ] не одинаково
Петренко1852
1)var a:array[1..4,1..4] of integer;
      i,j,s:integer;
begin
      for i:=1 to 4 do
         for j:=1 to 4 do 
               readln(a[i,j]);
         
           for i:=1 to 4 do begin 
                     writeln();
                   for j:=1 to 4 do begin 
                     write(a[i,j],' '); 
                    if (i+j>5) then s:=s+a[i,j];
                        end;
                 end;
writeln();
write(s);
end.

2)var a:array[1..4,1..4] of integer;
      i,j,s:integer;
begin
      for i:=1 to 4 do
         for j:=1 to 4 do 
               readln(a[i,j]);
         
           for i:=1 to 4 do begin 
                     writeln();
                   for j:=1 to 4 do begin 
                     write(a[i,j],' '); 
                    if (i>J) then s:=s+a[i,j];
                        end;
                 end;
writeln();
write(s);
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Ниже на пяти языках программирования записана рекурсивная функция (процедура) F. procedure F(n: integer); begin write(n); if n > 2 then begin F(n − 1); F(n − 2); F(n − 3) end end; Что выведет программа при вызове F(4)? В ответе запишите последовательность выведенных цифр слитно (без пробелов
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

pavpe4198
mausgaly
МихайловнаLarisa1150
irinasolodova3
Nadezhda Malakhov53
aguliaeva
qwqwweqw3
Раисовна878
georgegradoff122
ielienakozlova696
Abespal
tvmigunova551
asker45967
Negutsa_Kseniya524
katya860531
▲