mishamedbrat
?>

Тест по теме « Мои первые программы» Какое из названий не является языком программирования? а) Бейсик б) pascal в) Фортран г) WORD Что используется в качестве разделителей в языке Pascal? а) точка б) пробел в) точка с запятой г) тире Перечислите операции , допустимые в типе Integer Какой из приведенных ниже примеров не соответствует определению лексической единице « идентификатор»? А) х1 б) 1х в) suprafata г) I1j Определить, какие из ниже следующих констант относится к целым типам ? А) «привет» б) 583.0 в) 3333 г) «1234» 6. Укажите с стрелочек пары вещественных чисел , которые имеют одно и то же значение: 9, 35 * 〖10〗^7 -0.075 е-12 - 0, 075 * 〖10〗^(-12) 5.114е+1 -784 9.35е+7 51, 14 -0.784е+3 9.35е+7 7. Напишите обозначения функций на языке Pascal? а) квадрат числа х б)синус угла х в) корень квадратный из х г) абсолютное значение х 8. Найдите синтаксические ошибки . program p begin writeln я хочу знать информатику еnd 9. Сравните вещественные числа: 56.74е+3 56.74е-3 0.276е+4 276е+1 10 .Найдите пары эквивалентных идентификаторов: А3 gORoD Gorod XY01 AdreSA a3 X01Y x01y ADResa 11.Написать программу для вычисления по следующей формуле: у= x^3+2х+3

Информатика

Ответы

kim-1971

Тест по теме « Мои первые программы»

Какое из названий не является языком программирования?

г) WORD

Что используется в качестве разделителей в языке Pascal?

в) точка с запятой

Перечислите операции , допустимые в типе Integer

+, -, :, *, //,#.

Какой из приведенных ниже примеров не соответствует определению лексической единице « идентификатор»?

б) 1х

Определить, какие из ниже следующих констант относится к целым типам ?

в) 3333

Извиняюсь, на 7, 8, и 10 ответ не знаю (

8. Найдите синтаксические ошибки .

program p

begin

writeln ('я хочу знать информатику')

еnd

9. Сравните вещественные числа:

56.74е+3 > 56.74е-3

0.276е+4 > 276е+1

11.Написать программу для вычисления по следующей формуле:

у= x^3+2х+3

(Python script)

y = x^3+2х+3

print (y)

morozova4956
Второе красиво решил через строки MinGW GCC 4.7.1
#include <iostream>
#include <string>
#include <locale.h>
using namespace std;
char max(char a, char b)
{
return (a > b) ? a : b;
}
char min(char a, char b)
{
return (a < b) ? a : b;
}
int main(void)
{
setlocale(LC_ALL,"rus");
string s;
cout<<"Введите число: "; cin>>s;
char min_c = '9', max_c = '0';
for(size_t i = 0; i < s.length(); i++)
{
max_c = max(s[i], max_c);
min_c = min(s[i], min_c);
}
cout << "Наибольшая цифра: " << max_c << endl <<"Наименьшая цифра: " << min_c << endl;
return 0;
}
mar77873
В однобайтовом формате (8 бит) можно хранить 2^8 = 256 значений- от нуля до 255.

Если там посчитать 0 - 1, то байт перейдёт к значению 255.
А если посчитать 255 + 1, то байт перейдёт к нулевому значению
(т.е. 255 + 1 = 0 ).
Поэтому, можно рассматривать 255 как минус единицу (ведь  -1 + 1 = 0 ).

Так же и для минус семнадцати:
256 - 17 = 239

Если к 239 прибавить 17, то получим ноль в байте, так как 256 там не бывает, произойдёт перенос единицы в следующий байт (либо в бит признака переноса), а в этом байте останутся нули во всех битах.

ответ: 239

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Тест по теме « Мои первые программы» Какое из названий не является языком программирования? а) Бейсик б) pascal в) Фортран г) WORD Что используется в качестве разделителей в языке Pascal? а) точка б) пробел в) точка с запятой г) тире Перечислите операции , допустимые в типе Integer Какой из приведенных ниже примеров не соответствует определению лексической единице « идентификатор»? А) х1 б) 1х в) suprafata г) I1j Определить, какие из ниже следующих констант относится к целым типам ? А) «привет» б) 583.0 в) 3333 г) «1234» 6. Укажите с стрелочек пары вещественных чисел , которые имеют одно и то же значение: 9, 35 * 〖10〗^7 -0.075 е-12 - 0, 075 * 〖10〗^(-12) 5.114е+1 -784 9.35е+7 51, 14 -0.784е+3 9.35е+7 7. Напишите обозначения функций на языке Pascal? а) квадрат числа х б)синус угла х в) корень квадратный из х г) абсолютное значение х 8. Найдите синтаксические ошибки . program p begin writeln я хочу знать информатику еnd 9. Сравните вещественные числа: 56.74е+3 56.74е-3 0.276е+4 276е+1 10 .Найдите пары эквивалентных идентификаторов: А3 gORoD Gorod XY01 AdreSA a3 X01Y x01y ADResa 11.Написать программу для вычисления по следующей формуле: у= x^3+2х+3
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Alena824
Chuhnin195107364
Boris1247
TatianaSeliverstova64
kuk-nina
yyyaga
kobzev-e
qwerty
Шиловский126
ulyana-d
serkan777
hvostna23
Faed_Arakcheeva
brendacepedam
Shishkinaanasta1997
▲