Vladmouse32506
?>

Паскаль:через составной оператор Beginend составить программу, которая вычисляет сумму и среднее арифметическое положительных чисел

Информатика

Ответы

macmakka

Program p1;

Var a, i, n, k,z: integer;

Begin

Write('Введите количество чисел: ');

readln(n);

k:=0;

z:=0;

For i:=1 to n do begin

readln (a);

if (a > 0) then k:=k + a;

z:=z + 1;

end;

Writeln('Сумма положительных чисел = ',k);

Writeln('Среднее арифметическое чисел = ',k/z);

End.

kirill76536

тк Борисов жил с ученым из Ярославля, то Борисов не оттуда и не с Москвы и Санкт-Петербурга. следовательно, он с Новосибирска

Григорьев не Москвич и не с Ярославля. и теперь понятно, что не с Новосибирска. следовательно, он с Санкт-Петербурга

Егоров не с Москвы, остается один вариант, он с Ярославля

а Викторов значит с Москвы

можно сделать таблицу (по ней легко решать такие задачи):

                  Москва.   Новосиб.   С-п.   Ярославль.

Борисов.       -                 +               -              -

Викторов.     +                -                -              -

Григорьев.   -                 -                +             -

Егоров.         -                 -                -              +

metrikajulia

Басқа тілде оқу

Download PDF

Бақылау

Өңдеу

Ақпараттық қауіпсіздік — мемлекеттік ақпараттық ресурстардың, сондай-ақ ақпарат саласында жеке адамның құқықтары мен қоғам мүдделері қорғалуының жай-күйі.

Ақпаратты қорғауӨңдеу

Ақпаратты қорғау — ақпараттық қауіпсіздікті қамтамасыз етуге бағытталған шаралар кешені. Тәжірибе жүзінде ақпаратты қорғау деп деректерді енгізу, сақтау, өңдеу және тасымалдау үшін қолданылатын ақпарат пен қорлардың тұтастығын, қол жеткізулік оңтайлығын және керек болса, жасырындылығын қолдауды түсінеді. Сонымен, ақпаратты қорғау - ақпараттың сыртқа кетуінің, оны ұрлаудың, жоғалтудың, рұқсатсыз жоюдың, өзгертудің, маңызына тимей түрлендірудің, рұқсатсыз көшірмесін жасаудың, бұғаттаудың алдын алу үшін жүргізілетін шаралар кешені

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Паскаль:через составной оператор Beginend составить программу, которая вычисляет сумму и среднее арифметическое положительных чисел
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Ofelya1308
puchkovajulia
Акимцева27
Татьяна902
Leonidovich_Elena771
Ignateva737
ann-perminova2008
vallzh8328
lor005148
ПетровичЖивотовская1245
sohrokova809
aci2003
pbttehnology
Natalya1895
Blekjek730