dianabuchkina
?>

Напишите программу на алгоритмическом языке робот должен закрасить все отмеченные клетки и прийти на базу в клетку отмеченнуб буквой б используйте цикл н раз

Информатика

Ответы

perovd8111
1.var
   max,min,i:integer;
   b:real;
   a:array[1..9]of integer;
begin
for i:=1 to 9 do
  begin
  while (a[i]<1) or (a[i]>6) do
    begin
    write(i,' оценка: ');
    readln(a[i]);
    end;
  if i=1 then
    begin
    max:=a[1];
    min:=a[1];
    end;
  if a[i]>max then max:=a[i];
  if a[i]<min then min:=a[i];
  b:=b+a[i];
  end;
b:=(b-min-max)/7;
writeln('Зачетная оценка: ',b);
end. 

2. #include <stdafx.h> 
#include <stdio.h> 
#include <math.h> 
#include <stdlib.h> //for rand; 
int main()
 { 
int i, n,M[1]; 
 printf("Vvedit N:");
  scanf("%d",&n); 
for (i = 0; i < n; i++) 
 { 
  M[i] = rand()%10; 
    }
for (i = 0; i < n; i++) 
 { 
     printf("Array[%d] = %d\n", i, M[i]);
  } 
          scanf("%d"); 
return 0; 
}

3. var

a:array[0..9] of integer;
i,y,min:integer;
begin
randomize();
for i:=0 to 9 do
begin
y:= random(10);
a[i]:= y;
end;
for i:=0 to 9 do write(a[i],' ');
writeln(' - десять випадковых чисел');
min:=a[0];
for i:=1 to 9 do
if a[i]<min then min:=a[i];
writeln(min, ' - минимальне число.');

end. 

info664
Const
  n = 10;

var
  a,b: array[1..n] of integer;
  i, s, imax, smax: integer;

begin
  Randomize;
  Writeln('Элементы массива A');
  for i := 1 to n do
  begin
    a[i] := Random(30)+5;
    Write(a[i]:3);
  end;
  Writeln;
  smax:=0; imax:=0;
  Writeln('Элементы массива B');
  for i := 1 to n do
  begin
    b[i] := Random(30)+5;
    Write(b[i]:3);
    s:=a[i]*b[i];
    if smax<s then begin imax:=i; smax:=s end
  end;
  Writeln;
  Writeln('Прямоугольник номер ',imax,' имеет максимальную площадь ',
    a[imax],'x',b[imax],'=',smax)
end.

Тестовое решение:
Элементы массива A
 31 30 34  9 12 11 11 24 34 29
Элементы массива B
 18 16 15 16 19 22 24 22 25  5
Прямоугольник номер 9 имеет максимальную площадь 34x25=850

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу на алгоритмическом языке робот должен закрасить все отмеченные клетки и прийти на базу в клетку отмеченнуб буквой б используйте цикл н раз
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Ruslan374
YaroslavSerganYS5
Лебедев972
ВитальевичЕвгеньевич346
Vyacheslavovich1431
Манько_Панферов
irinakiral
helenavalenti2846
Olenkalebedeva4477
Salkinserg
Railyan
argent
shumeikoElena362
saint158
Yuliya-Tsaryova