Викторовна
?>

Извиняюсь, мало , но Напишите программу, которая получает трёхзначное число и определяет, верно ли, вего записи есть одинаковые цифры (программа должна вывести ответ «да» или «нет»

Информатика

Ответы

hobpack

зайди в плей маркет и там можно найти

Konstantin_Vadimirovich
1. Вот так это пишется с функцией

// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
function IsPrime(n:integer):boolean;
begin
  if n<4 then Result:=True
  else begin
    var found:= (n mod 2 = 0);
    var p:=3;
    while (not found) and (sqr(p)<=n) do
      begin
      found:=(n mod p = 0);
      p+=2
      end;
    Result:=not found
    end
end;

begin
  Writeln('k=',ArrRandom(ReadInteger('n='),1,999).Println.
    Where(x->IsPrime(x)).Count)
end.

Тестовое решение:
n= 10
401 828 780 444 694 965 23 341 673 875
k=3

2. А вот так это пишется с процедурой

// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
procedure IsPrime(n:integer; var res:boolean);
begin
  if n<4 then res:=True
  else begin
    var found:= (n mod 2 = 0);
    var p:=3;
    while (not found) and (sqr(p)<=n) do
      begin
      found:=(n mod p = 0);
      p+=2
      end;
    res:=not found
    end
end;

begin
  var a:=ArrRandom(ReadInteger('n='),1,999); a.Println;
  var k:=0;
  var prime:boolean;
  foreach var e in a do begin
    IsPrime(e,prime);
    if Prime then Inc(k)
    end;
  Writeln('k=',k)
end.

Тестовое решение:
n= 12
199 43 71 365 417 904 170 212 694 103 161 689
k=4
magazin7452834
Информационная деятельность - это совокупность действий, направленных на удовлетворение информационных потребностей граждан, юридических лиц и государства.
В целях удовлетворения этих потребностей органы государственной власти и органы местного и регионального самоуправления создают информационные службы, системы, сети, базы и банки данных.
Порядок их создания, структура, права и обязанности определяются Кабинетом Министров Украины или другими органами государственной власти, а также органами местного и регионального самоуправления.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Извиняюсь, мало , но Напишите программу, которая получает трёхзначное число и определяет, верно ли, вего записи есть одинаковые цифры (программа должна вывести ответ «да» или «нет»
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Ruzalina_Svetlana1435
bezpalova2013
Ivanova.i.bkrasheninnikov
nchalov2
bogdanovaoksa
Olegmgu11986
punchf
reception
daryagulyaeva
iamhrusha
rina394992
Vasilevna_Mikhail19
Матвеев
Mariya Filippov
bd201188