1) uses crt;
var a,s:real;
i,n:integer;
begin
write('Введите число А: ');
readln(a);
write('Введите число N: ');
readln(n);
s:=1;
for i:=1 to n do begin
s:=s*a;
end;
writeln('Число ',a,' в степени ',n,' равно ',s);
end.
2)uses crt;
var a,s:real;
i,n:integer;
begin
write('Введите число А: ');
readln(a);
write('Введите число N: ');
readln(n);
s:=1;
for i:=1 to n do begin
s:=s*a;
writeln(a,' в степени ',i,' равно ',s);
end;
end.
3)uses crt;
var a,s,p:real;
i,n:integer;
begin
write('Введите число А: ');
readln(a);
write('Введите число N: ');
readln(n);
s:=1;
p:=1;
write('1 + ');
for i:=1 to n do begin
s:=s*a;
p:=p+s;
if i<n then write(s,' + ');
if i=n then write(s,' = ');
end;
writeln(p);
end.
Поделитесь своими знаниями, ответьте на вопрос:
Tasm Напишите программу, которая складывает поэлементно два массива X и Y и помещает результат в массив Z. Размер элементов – 8 байт (длинное вещественное), количество элементов – 20.
program fofgogjoj;
var
n,i : integer;
a,p : real;
begin
Writeln('Введите число.');
Readln(a);
Writeln('Введите степень');
Readln(n);
p:=1;
for i:=1 to n do
begin
p:=p*a;
end;
if a<0 then
p:=1/p;
Writeln(p :6:3);
readln;
end.
FOR16
program fofgogjoj;
var
i, n: integer;
a, p: real;
begin
Writeln('Введите число:');
Write(' a = ');
Readln(a);
Writeln('Введите показатель степени (n > 0):');
Write(' N = ');
Readln(N);
Writeln('Все степени числа ', a, ' от 1 до ', n, ':');
p:= 1;
for i:=1 to n do
begin
p:= p*a;
Writeln(' ', a, ' в степени ', i, ': ', p:0:2)
end
end.