1 )В кодовых таблицах КОИ-8 и Windows сначала расположены прописные русские буквы, а затем строчные. Русские прописные буквы в кодовых таблицах КОИ-8 и Windows имеют номера со 192 по 223. Русские буквы в кодовых таблицах КОИ-8 и Windows имеют номера со 192 по 225.
2)
film
face
fine
fire
3)3
4) i = 1 байт
k = «Речь вести - не лапти плести.»
Найти:
V - ?
Решение
i = 1 байт = 8 бит
В предложении «Речь вести - не лапти плести.»- 29 символов
V = k * i (формула нахождение объёма текстовой информации)
Где, к – количество символов в тексте
V = 29 * 8 = 232 бит = 29 байт
ответ: текст содержит 29 байт информации
5 )Слово занимает 14 байт =14*8=112 бит памяти. Решение: Переведем Кб в байты: 0, 25 Кб * 1024 =256 байт. Так как текст занимает объем 256 байт, а каждый символ – 1 байт, то в тексте 256 символов.
6)31 управляющие
7)4
8)576 битов тоесть :576/8=72 бита
Поделитесь своими знаниями, ответьте на вопрос:
составьте программу для PascalСтрока состоит из двух слов. Поменяйте эти слова местами.Входные данные :На вход программе подается строка, состоящая не более чем из 255 символов. Строка содержит ровно один пробел, разделяющий два слова. Строки кодированы в KOI8-RUВыходные данные:Выведите преобразованную строку, по-прежнему разделяя слова ровно одним пробелом.Примерывходные данныеabcd efвыходные данныеef abcd
var
a:array [1..100] of integer;
i,n:integer;
begin
writeln('Введите n <=100');
readln(n);
writeln('Введите массив');
for i:=1 to n do
readln(a[i]);
writeln('Массив');
for i:=1 to n do
write(a[i], ' ');
writeln;
writeln('Элементы равные сумме двух соседей:');
for i:=2 to (n-1) do
if a[i]=(a[i-1]+a[i+1]) then write(a[i],' ');
writeln;
end.
задача 5
var
a:array [1..10000] of integer;
i,n, mx1, mx2:integer;
begin
writeln('Введите n <=10000');
readln(n);
writeln('Введите массив');
for i:=1 to n do
readln(a[i]);
writeln('Массив');
for i:=1 to n do
write(a[i], ' ');
writeln;
mx1:=1;
for i:=2 to n do
if a[i]>a[mx1] then mx1:=i;
if mx1=1 then mx2:=2 else mx2:=1;
for i:=1 to n do
if (a[i]>a[mx2])and(i<>mx1) then mx2:=i;
writeln('Два числа произведение которых максимально: ',a[mx2],' ',a[mx1]);
end.