espectr-m
?>

Напишите программу на Pascal: Напишите среднее значение целых положительных чисел, которые вводятся с клавиатуры (окончание ввода-ввод числа 0)

Информатика

Ответы

leonid-adv70

//Pascal

var a,i,s,n:integer;

begin

 s:=0;

 n:=0;

 repeat

    readln(a);

    if a>0 then begin

       n:=n+1;

       s:=s+a;

    end;

 until a = 0;

 writeln('Сумма ',s:5,'  Среднее арифметическое ',s/n);

end.

ТАК) (Я НЕСОВСЕМ УВЕРЕН)

egolopuzenko4253

--- PascalABC.NET 3.6.2 ---

begin

 ReadSeqIntegerWhile(p -> p <> 0).Where(p -> p > 0).Average.Println;

end.

nastikak8

Я всё вижу по глазам

Что ты хочешь мне сказать

(На-на-на-на, а-а-а)

Я не буду тебя знать, а ты меня

(Ты меня, ты меня, ты меня, ты меня)

И мы друг друга (Ты меня)

Под ногами лёд, и в сердце лёд

В стакане лёд, я не помню кто я

Душит мороз, я такой холодный

Я такой холодный!

Я читаю по губам

Мне нечего сказать

(На-на-на-на, а-а-а)

Я не вижу смысла врать (а-а)

Мне хватит слов, что я сказал

(Не вижу смысла врать)

В 7:30 утра автобус врезался в автомобиль марки Suzuki

И какое-то время, буквально тащил его, по ходу движения

Как подтвердили в ГИБДД

Одиннадцатилетняя девочка — пассажирка Suzuki погибла в огне

Где находилась её мама, которая пыталась ребенка

Что же случилось — ещё предстоит выяснить

Следователи сейчас проводят проверку

krutikovas

#Сюда пишем массив

Massive = [1, -3, 10, 222, -30, -10]

#Переменная для опредиления суммы отрицательных эллементов массива

Sum = 0

#Переменная для опредиления кол-ва отрицательных эллементов массива

Count = 0

#Переменная для подсчета среднего арифметического

Avg = 0

#Цыкл, в ходе которого мы находим сумму и кол-во отрицательных эллементов массива  

for elements in Massive:

   if elements < 0:

      Sum = elements + Sum

      Count = Count + 1

#Подсчет и округление среднего арефметического

if Count > 0:

   Avg = int(Sum / Count)

#Вывод среднего арефметического

print(Avg)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу на Pascal: Напишите среднее значение целых положительных чисел, которые вводятся с клавиатуры (окончание ввода-ввод числа 0)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Сурат1199
VASILEVNA
bryzgalovag
bel1-79
postbox
Wlad967857
khadisovam9
cvetyzelen283
valya-7777
tcmir
denspiel
Apresov
lyukiss
kristal1
Ligacom