postbox
?>

Дано четырехзначное число. Написать программу, которая выводит на экран число, образованное при перестановке первой и второй, третьей и четвертой цифр заданного числа

Информатика

Ответы

Герасименко
Const
  n=40;
var
  i,s1,s2,k:integer;
  s:real;
  a:array[1..n] of integer;
begin
  Randomize;
  Write('Сгенерированный массив: ');
  s:=0; s1:=0; s2:=0; k:=0;
  for i:=1 to n do begin
    a[i]:=Random(21);
    Write(a[i],' ');
    if a[i] mod 2<>0 then begin s:=s+a[i]; Inc(k) end;
    if a[i]<=10 then s1:=s1+a[i];
    if a[i] mod 3=0 then s2:=s2+a[i]
    end;
  Writeln;
  Writeln('Ср.арифм.нечетных = ',s/k);
  Writeln('Сумма не больших 10 = ',s1);
  Writeln('Сумма кратных 3 = ',s2)
end.

Пример выполнения программы
Сгенерированный массив: 14 19 1 5 0 2 1 3 2 15 5 3 18 0 4 12 5 0 9 2 14 7 18 13 0 16 9 15 19 14 13 13 16 16 1 16 14 2 1 1
Ср.арифм.нечетных = 7.9
Сумма не больших 10 = 63
Сумма кратных 3 = 102

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дано четырехзначное число. Написать программу, которая выводит на экран число, образованное при перестановке первой и второй, третьей и четвертой цифр заданного числа
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

grekova5
Valerii276
vitaliy
nsoro937
chuev4444
olgalooo
dmtr77
Darialaza
starabanov
Vyacheslavovna
stalker2201
cardiodoc08
Светлана-Тигран
Сделайте 1 или 2 задание ​
Карева Даниил1537
Demina-Khokhlov584