ryazantseva
?>

1) Разработчиком языка Паскаль является: 1. Блез Паскаль 2. Никлаус Вирт 3. Норберт Винер 4. Эдсгер В. Дейкстра 2) Что из нижеперечисленного НЕ входит в алфавит языка Пас­каль? 1. латинские строчные и прописные буквы 2. служебные слова 3. русские строчные и прописные буквы 4. знак подчёркивания 3) Какая последовательность символов НЕ может служить именем в языке Паскаль? 1. _mas 2. maS1 3. d2 4. 2d 4) Вещественные числа имеют тип данных: 1. real 2. integer 3. boolean 4. string 5) В программе на языке Паскаль обязательно должен быть: 1. заголовок программы 2. блок описания используемых данных 3. программный блок 4. оператор присваивания 6) Какого раздела не существует в программе, написанной на языке Паскаль? 1. заголовка 2. примечаний 3. описаний 4. операторов 7) Языковые конструкции, с которых в программах за­писываются действия, выполняемые в процессе решения зада­чи, называются: 1. операндами 2. операторами 3. выражениями 4. данными 8) Разделителями между операторами служит: 1. точка 2. точка с запятой 3. пробел 4. запятая 9) Описать переменную — это значит указать её: 1. имя и значение 2. имя и тип 3. тип и значение 4. имя, тип и значение 10) В данном фрагменте программы: program error; begin SuMmA:=25-14; end. ошибкой является: 1. некорректное имя программы 2. не определённое имя переменной 3. некорректное имя переменной 4. запись арифметического выражения 11) Какая клавиша нажимается после набора последнего данного в операторе read? 1. Enter 2. точка с запятой 3. пробел 4. Ctrl 12) При присваивании изменяется: 1. имя переменной 2. тип переменной 3. значение переменной 4. значение константы 13) Для вывода результатов в Паскале используется оператор: 1. begin 2. readln 3. write 4. print 14) Для вычисления квадратного корня из х используется функ­ция: 1. abs (х) 2. sqr (х) 3. sqrt(х) 4. int (х) 15) Для генерации случайного целого числа из интервала [10, 20) необходимо использовать выражение: 1. random*20 2. random (20) 3. random(10)+10 4. random(10)*2

Информатика

Ответы

Iselickaya1890
DIM ch$(26)
FOR i = 1 TO 26
ch$(i) = CHR$(ASC("a") + i - 1)
NEXT

DIM cw(26) AS LONG

PRINT "text:"
INPUT "", s$
DO WHILE s$ <> "*"
s$ = s$ + " "
iw = 0
FOR i = 1 TO LEN(s$)
c$ = MID$(s$, i, 1)
IF iw = 0 AND c$ <> " " THEN
iw = 1
idx = ASC(c$) - ASC("a") + 1
cw(idx) = cw(idx) + 1
ELSEIF iw = 1 AND c$ = " " THEN
iw = 0
END IF
NEXT
INPUT "", s$
LOOP

FOR i = 1 TO 25
m = i
FOR j = i TO 26
IF cw(j) > cw(m) OR (cw(j) = cw(m) AND ch$(j) < ch$(m)) THEN
m = j
END IF
NEXT
IF m <> i THEN
tmp = cw(m)
cw(m) = cw(i)
cw(i) = tmp
tmp$ = ch$(m)
ch$(m) = ch$(i)
ch$(i) = tmp$
END IF
NEXT

FOR i = 1 TO 26
IF cw(i) <> 0 THEN
PRINT ch$(i) + ":"; cw(i)
END IF
NEXT
praskovya17
Если будут где-то ошибки извините ,возможно в знаках)) проверьте в паскале ,если что напишите 

program prazdnik;
var a : integer ;
begin
readln(a);
if a=1  then writeln ('пишите сюда праздиники в первый месяц,какие нужны');
if a=2 then writeln ('сюда то чт ово второй ');
if a=3 then writeln (' третий ') ;
if a=4 then writeln (' четвертый месяц с его праздниками');
if a=5 then writeln (' пятый месяц');
  if a=6 then writeln (' шестой месяц'); 
 if a=7 then writeln (' седьмой месяц'); 
 if a=8 then writeln (' восьмой'); 
 if a=9 then writeln (' праздники '); 
 if a=10 then writeln ('празники '); 
  if a=11 then writeln (' праздники 11 месяца');
 if a=12 then  writeln ('двенадцатый');  
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1) Разработчиком языка Паскаль является: 1. Блез Паскаль 2. Никлаус Вирт 3. Норберт Винер 4. Эдсгер В. Дейкстра 2) Что из нижеперечисленного НЕ входит в алфавит языка Пас­каль? 1. латинские строчные и прописные буквы 2. служебные слова 3. русские строчные и прописные буквы 4. знак подчёркивания 3) Какая последовательность символов НЕ может служить именем в языке Паскаль? 1. _mas 2. maS1 3. d2 4. 2d 4) Вещественные числа имеют тип данных: 1. real 2. integer 3. boolean 4. string 5) В программе на языке Паскаль обязательно должен быть: 1. заголовок программы 2. блок описания используемых данных 3. программный блок 4. оператор присваивания 6) Какого раздела не существует в программе, написанной на языке Паскаль? 1. заголовка 2. примечаний 3. описаний 4. операторов 7) Языковые конструкции, с которых в программах за­писываются действия, выполняемые в процессе решения зада­чи, называются: 1. операндами 2. операторами 3. выражениями 4. данными 8) Разделителями между операторами служит: 1. точка 2. точка с запятой 3. пробел 4. запятая 9) Описать переменную — это значит указать её: 1. имя и значение 2. имя и тип 3. тип и значение 4. имя, тип и значение 10) В данном фрагменте программы: program error; begin SuMmA:=25-14; end. ошибкой является: 1. некорректное имя программы 2. не определённое имя переменной 3. некорректное имя переменной 4. запись арифметического выражения 11) Какая клавиша нажимается после набора последнего данного в операторе read? 1. Enter 2. точка с запятой 3. пробел 4. Ctrl 12) При присваивании изменяется: 1. имя переменной 2. тип переменной 3. значение переменной 4. значение константы 13) Для вывода результатов в Паскале используется оператор: 1. begin 2. readln 3. write 4. print 14) Для вычисления квадратного корня из х используется функ­ция: 1. abs (х) 2. sqr (х) 3. sqrt(х) 4. int (х) 15) Для генерации случайного целого числа из интервала [10, 20) необходимо использовать выражение: 1. random*20 2. random (20) 3. random(10)+10 4. random(10)*2
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

gordeevadesign2986
zakup-r51
Елена-Семенова
elozinskaya
oafanasiev41
Платон Демцун
hrim5736
Васильевичь Виктория457
olesyashazk5055
iraimironova
denisrogachv
Japancosmetica
annashersheva
suhovaab
kapustina198690