Поделитесь своими знаниями, ответьте на вопрос:
Задача №66. Количество элементов, больших предыдущего Числа следует выводить через пробел. Все числа целые, по модулю не больше 231-1. Количество элементов массива не превышает 10000. Дан массив, состоящий из целых чисел. Напишите программу, которая подсчитает количество элементов массива, больших предыдущего (элемента с предыдущим номером Входные данные Сначала задано число N — количество элементов в массиве (1≤N≤10000). Далее через пробел записаны N чисел — элементы массива. Массив состоит из целых чисел. Выходные данные Необходимо вывести единственное число - количество элементов массива, больших предыдущего. Примеры входные данные 5 1 2 3 4 5 выходные данные 4 НА С++ ПЛЗ
#include <iostream>
#include <vector>
using namespace std;
int main() {
int n;
cin >> n;
vector <int> a;
int p = 0;
for (int i = 0; i < n; i++) {
int temp;
cin >> temp;
a.push_back(temp);
}
for (int i = 1; i < n; i++) {
if (a[i] > a[i - 1])
{
p++;
}
}
cout << p;
}