pavpe4198
?>

Написать программу на Паскаль с использованием функции, которая вычисляет следующее выражение.

Информатика

Ответы

lobutev
Var
i,j,k:longint;
    begin
         for i:=1 to 1000 do
              for j:=1 to 1000 do       
                   for k:=1 to 10000 do             
                      if sqr(i)+sqr(j)=sqr(K)then               
                           begin                 
                                writeln(i,' ',j,' ',k);  {вывожу все тройки, можно убрать}             
                                     if i+j+k=1000 then                 
                                          begin                 
                                               writeln('! ',i,' ',j,' ',k);  {нужная тройка}                
                                                exit; {прерывание программы}                
                                          end;               
                           end;   
     end.


Существуют тройки пифагора, то есть a^2+b^2=c^2 . есть лишь одна такая тройка, что a+b+c=1000 . напи
siyaniemoskva
program cube; var a : real; begin writeln('Программа вычисляет объем куба и площадь '+ 'его боковой поверхности по длине ребра'); {I - ввод + ЗОД} repeat write('Введите длину ребра куба '); readln(a); if a<=0 then writeln('Ошибка! Длина ребра не может быть нулевой или отрицательной. '+ 'Повторите ввод.'); until a>0; {II, III - расчет и вывод} writeln('Длина ребра куба = ',a:8:3,' м'); writeln('Объем этого куба = ', (a*a*a):8:3,' м^3'); writeln('А площадь его боковой поверхности = ', (6*a*a):8:3,' м^2'); writeln('Нажмите [Enter] для завершения программы'); readln; end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на Паскаль с использованием функции, которая вычисляет следующее выражение.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

olechka197835
Kazantsevv_kostya
Vadim443
sbraginets
aivia29
aistenok-28
ilyxa08
sinicin80
tyrenumberone
Александровна1685
Barabanov Gerasimenko
nordwokintos4
Игоревна
YekaterinaAbinskov
Lukina