dmitrievanata83538
?>

PascalABC. Написать программу, в которой выполняются следующие действия: 1. с клавиатуры вводится имя 1-го человека; 2. с клавиатуры вводится вес 1-го человека; 3. с клавиатуры вводится имя 2-го человека; 4. с клавиатуры вводится вес 2-го человека; 5. программа выводит имя более тяжелого человека (при равенстве весов выводится имя 2-го человека); 6. в том случае, когда вес какого-либо человека или обоих не находится в пределах от 3 до 150 программа выводит только сообщение «ошибка».

Информатика

Ответы

dlydesertov1

var

a, b:String;

c, d:Integer;

begin

readln(a);

readln(c);

if (c < 3) or (c  > 150)

then begin

 writeln('Ошибка');

 exit;

 end;

readln(b);

readln(d);

if (d < 3) or (d  > 150)

then begin

 writeln('Ошибка');

 exit;

end;

if c > d then  

 writeln(a)

else  

writeln(b);

end.

olesyadeinega41
Наивные
- загадываем число. Прибавляем к нему 7. Отнимаем загаданное число.
x + 7 - x = 7
- загадываем число. Умножаем его на 7. Делим на загаданное число (не сработает для нуля)
x * 7 / x = 7

Можно немного это замаскировать:
- загадываем число. Умножаем его на 15873. Прибавляем 111111. Делим на 15873. отнимаем загаданное число.
(15873x + 111111)/15873 - x = 7

Можно использовать какой-нибудь фокус, например, складывание сумм цифр до тех пор, пока не получится одно число (т.н. "числовой корень", пример: 255 -> 2 + 5 + 5 = 12 -> 1 + 2 = 3)
- загадываем натуральное число. Умножаем на 9, находим числовой корень. Отнимаем 2.
Разгадка в том, что числовой корень любого числа, делящегося на 9 и не равного нулю, равен 9.

Маскировка:
- загадываем натуральное число. Умножаем на 777 и находим числовой корень. Потом на 666 и находим числовой корень. Прибавляем к результату 666. Находим сумму кубов цифр результата. И еще раз. Смотрим на число сотен результата.
666 делится на 9, так что числовой корень числа (666 * что-то) равен 9. 666 + 9 = 675. 6^3 + 7^3 +5^3 = 684. 6^3 + 8^3 + 4^3 = 792
ostapbender1111
Наивные
- загадываем число. Прибавляем к нему 7. Отнимаем загаданное число.
x + 7 - x = 7
- загадываем число. Умножаем его на 7. Делим на загаданное число (не сработает для нуля)
x * 7 / x = 7

Можно немного это замаскировать:
- загадываем число. Умножаем его на 15873. Прибавляем 111111. Делим на 15873. отнимаем загаданное число.
(15873x + 111111)/15873 - x = 7

Можно использовать какой-нибудь фокус, например, складывание сумм цифр до тех пор, пока не получится одно число (т.н. "числовой корень", пример: 255 -> 2 + 5 + 5 = 12 -> 1 + 2 = 3)
- загадываем натуральное число. Умножаем на 9, находим числовой корень. Отнимаем 2.
Разгадка в том, что числовой корень любого числа, делящегося на 9 и не равного нулю, равен 9.

Маскировка:
- загадываем натуральное число. Умножаем на 777 и находим числовой корень. Потом на 666 и находим числовой корень. Прибавляем к результату 666. Находим сумму кубов цифр результата. И еще раз. Смотрим на число сотен результата.
666 делится на 9, так что числовой корень числа (666 * что-то) равен 9. 666 + 9 = 675. 6^3 + 7^3 +5^3 = 684. 6^3 + 8^3 + 4^3 = 792

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

PascalABC. Написать программу, в которой выполняются следующие действия: 1. с клавиатуры вводится имя 1-го человека; 2. с клавиатуры вводится вес 1-го человека; 3. с клавиатуры вводится имя 2-го человека; 4. с клавиатуры вводится вес 2-го человека; 5. программа выводит имя более тяжелого человека (при равенстве весов выводится имя 2-го человека); 6. в том случае, когда вес какого-либо человека или обоих не находится в пределах от 3 до 150 программа выводит только сообщение «ошибка».
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ielienakozlova696
tarasova
rusart3
vakhitov100961
abrolchik8511
ilkindadashov935232
superbalsa
akakne86
АнжелаВасильевич
Алёна Геннадьевна98
diana0720
gostivdom302
deshkina82
v-shevlyakov7992
skorpion7228528