proplenkusale88
?>

Программирование на языке Puthon Представь, что кадеты Марсакадемии играют в «лесенку»: первый подтянулся a раз. Второй на 1 раз больше. Первый снова на 1 раз больше, и так далее. В последний раз игрок сумел подтянуться b раз. Сколько всего подтягиваний было в игре? Написать программу на языке puthon при цикла while. Можно использовать if, else, >=, <=, ==, !=. желательно с обьяснениями #

Информатика

Ответы

drappaeva68

b = int(input("До скольки подтягиваний дошли : "))

c = 0

i = 1

while b > i:

   i += 1

   c += i

print(c + 1)

Объяснение:

Да не самое компактное, но...

akinin95

Запишем условие задачи:

Поскольку в сообщениях одинаковое количество символов, то К1=К2. Соотношение количества информации можно записать как I1=1.5*I2. Общее кол-во символов в алфавите обозначается буквой N, по условию N1<=10, N2<=10.

Решение: I1=K1*i1; I2=K2*i2; Подставим в условие I1=1.5*I2 значения I1 и I2. Получаем K1*i1=1.5*K2*i2

Сократим в обеих частях уравнения К1 и К2, у нас останется

i1=1.5*i2

По условию мощности обоих алфавитов не превышают число 10, запишем это так

10>=2 в степени i1

10>=2 в степени i2

Предположим, что i2=1 бит, тогда i1=1.5 бита (а это противоречит условию)

Предположим, что i2=2 бита, тогда i1=3 бита -это и есть ответ задачи


tatk00
1) собирается - журналист опрашивает людей для статьи
2) обрабатывается - ученик решает уравнение
2) упрощается - преподователь объясняет материал 
3) создается - журналист придумывает статью
4) запоминается - парнень запоминает номер телефона девушки
5) измеряется - программист рассчитывает сколько бит займет 
программа
6) копируется - ученик списывает у одноклассника
7) передается - две девушки обмениваются новостями
8) принимается - ученики слушают учителя на уроке
9) разрушается - статья журналиста отвергается
10) делится на части - человек разбирает сообщение в котором 
пропущены пробелы
11) ищется - человек ищет материал для реферата в интернете

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Программирование на языке Puthon Представь, что кадеты Марсакадемии играют в «лесенку»: первый подтянулся a раз. Второй на 1 раз больше. Первый снова на 1 раз больше, и так далее. В последний раз игрок сумел подтянуться b раз. Сколько всего подтягиваний было в игре? Написать программу на языке puthon при цикла while. Можно использовать if, else, >=, <=, ==, !=. желательно с обьяснениями #
Ваше имя (никнейм)*
Email*
Комментарий*